/srv/irclogs.ubuntu.com/2009/09/29/#launchpad-reviews.txt

=== barry` is now known as barry
mwhudsonanyone around?03:36
henningejtv: Hi! Can you please review this patch of mine, that adds a test to yesterday's branch?08:17
henninge;-)08:17
henningejtv: http://paste.ubuntu.com/281070/08:17
henningejtv: I was in fact able to test it by going a bit deeper into the inner structure of the job.08:19
jtvhenninge: that's what I figured yesterday, but the question was whether it's worth the trouble.08:19
jtvDoesn't look like too much work though08:20
henningejtv: once I thought of it, it was not too hard to write, no.08:20
henningejtv: the test case already has a lot of useful helper methods.08:20
jtvhenninge: but do you know that this test exercises the problem case?  I don't see a guarantee in there that there will be a directory in the set of changes.08:21
henningejtv: the method _makeBranch... creates the directory in the branch, so it does come up as changed.08:22
jtvah08:22
henningejtv: I also tried it out when my fix is removed and the test does fail, with the first assert finding three elements in the list.08:23
jtvIs there an easy way you can check that in the test?08:23
henningejtv: I am passing NULL_REVISON to the job, so it asks bzrlib for all changes since the creation of the branch, so the directories *will* always be included.08:24
jtvhenninge: very well.  Another point: why all the trouble asserting the contents of those two lists?  You know what's in them, just assertEquals.08:26
jtvah, you extract the paths08:26
henningejtv: well, it could be that just a directory got extracted, instead of the file ...08:26
henningejtv: but what I could do, is check that all in one assert08:27
henningejtv: ah, no, not easily.08:27
jtvyou could self.assertEqual([pot_path], [x[0] for x in job.template_files_changed])08:28
henningejtv: yes. Do you find that easier to read?08:28
henningeI was thinking along the lines of08:29
jtvhenninge: I find it easier to read with a little helper for the repetitive parts08:29
jtvself.assertEqual([pot_path], get_paths(job.template_files_changed))08:29
henninge self.assertEqual([(pot_path, pot_content], job.template_files_changed)08:29
henningebut I'd have to procide pot_content, with is a UniqueString atm.08:30
henningeprovide08:30
henningeoh, could do that ...08:30
henningejtv: incremental diff: http://paste.ubuntu.com/281080/08:33
jtvhenninge: why bother with unique strings for the content?  Just pass "# empty" or something08:34
jtvThe code does get a lot shorter though, which shows you're on to something.08:35
henningejtv: I have been told that if a string is arbitrary, just say so be using UniqueString.08:35
henningewhich makes sense to me08:35
henningejtv: full difff: http://paste.ubuntu.com/281081/08:35
jtvhenninge: in this case, it isn't _entirely_ arbitrary: it's supposed to be in gettext.  And you're not trying to catch bzr passing the wrong file contents, and there's no risk of accidentally picking up data from elsewhere.08:36
henningejtv: right, it is not about the content at all08:37
henningejtv: but this is needed to make the assert easy to write because the tuple contains the content.08:38
henningetuples08:38
jtvSure.  r=jtv.08:38
henningejtv: thank you!08:39
henningejtv: btw, this is how a failure looks, which I think comes out nicely now:08:40
henningeAssertionError: not equal:08:40
henningea = [(u'subdir/foo.pot', 'generic-string1')]08:40
henningeb = [(u'subdir/foo.pot', 'generic-string1'), (u'subdir', ''), ('', '')]08:40
jtvhenninge: not surprising.  :)  Yes, looks good.08:41
=== henninge_ is now known as henninge
allenapHello gmb, fancy a very very small branch to kick the day off?10:11
gmballenap: Sure.10:11
allenaphttps://code.edge.launchpad.net/~allenap/launchpad/itch/+merge/1257610:11
allenapgmb: Thank you :)10:12
=== gmb changed the topic of #launchpad-reviews to: on call: gmb || reviewing: allenap || queue: [] || This channel is logged: http://irclogs.ubuntu.com/
gmballenap: Land it :)10:14
allenapgmb: Thanks :)10:14
adeuringgmb: could you please review this branch: https://code.edge.launchpad.net/~adeuring/launchpad/bug-438169-parse-sysfs-attr/+merge/12577 ?10:45
gmbadeuring: Certainly.10:45
=== gmb changed the topic of #launchpad-reviews to: on call: gmb || reviewing: adeuring || queue: [] || This channel is logged: http://irclogs.ubuntu.com/
adeuringgmb: thanks!10:45
gmbadeuring: Looks like you've committed at least part of  a conflict in lib/canonical/launchpad/scripts/hwdbsubmissions.py (the <<<<<<< TREE line is there in the diff)10:53
adeuringgmb: Ah, right; there are conflicts with a brnach I submitted yesterday.10:54
gmbadeuring: In fact it looks like the entire conflict has been committed.10:54
gmbadeuring: Okay. Please fix that and paste a diff; I'll review everything that's not conflicted.10:55
adeuringgmb: let me see... I did not notice any conflict yersterday...10:55
gmbadeuring: Argh, according to the MP test_hwdb_submission_parser.py has the same problem - unresolved conflicts have been committed.10:57
gmbadeuring: I'll reject this mp and you can resubmit (otherwise the diff will never get updated)10:57
adeuringgmb: ok10:57
adeuringgmb: conflict resolved.11:14
gmbadeuring: Cool. Please submit a fresh mp so that I get a clean diff.11:14
adeuringgmb: I already resubmiitted the the MP11:15
gmbadeuring: Oh, cool.11:15
gmbLooking now, then :)11:15
adeuringgmb: scrap that -- i did mot wait long enough after pushing the latest version of the brnach...11:17
gmbHa.11:18
gmbadeuring: So, what's the situation... should I just merge your branch into a clean branch of devel and do this the old fashioned way or do you want to delete the old MP and create a new one?11:42
adeuringgmb: I_m waiting thatthe latest version of the brnach appears on LP...11:42
gmbadeuring: Ok.11:43
adeuringI should perhaps simply delete the brnach and and push it again..11:43
gmbadeuring: That might work, yes.11:49
gmbadeuring: Or push --overwrite, but I'd favour the first option myself.11:49
adeuringgmb: https://code.edge.launchpad.net/~adeuring/launchpad/bug-438169-parse-sysfs-attr/+merge/1258111:50
* gmb looks11:50
gmbadeuring: Ah, that looks much saner.11:50
gmbadeuring: To make that test nicer in test_hwdb_submission_parser.py you could use dedent() rather than removing all the indentation from the sysfs-attributes string.11:53
gmbAt the moment it looks quite ugly.11:53
adeuringgmb: right; will do11:53
gmbadeuring: Also in that test, the opening braces of dicts shouldn't be on a line of their own. Better to put them on the end of the line above.11:54
gmb(I'm talking about the assertEqual() call here)11:54
gmbadeuring: Other than that, r=me.11:57
adeuringgmb: thanks!11:57
=== gmb changed the topic of #launchpad-reviews to: on call: gmb || reviewing: - || queue: [] || This channel is logged: http://irclogs.ubuntu.com/
=== matsubara-afk is now known as matsubara
cprovgmb: accepting reviews ?13:14
gmbcprov: Just about to grab some lunch, but I'll put it on the queue for when I return.13:14
=== gmb changed the topic of #launchpad-reviews to: on call: gmb || reviewing: - || queue: [cprov] || This channel is logged: http://irclogs.ubuntu.com/
cprovgmb: https://code.edge.launchpad.net/~cprov/launchpad/bug-408528-ensurePerson-again/+merge/1258313:14
* gmb lunches13:15
cprovgmb: thank you.13:15
=== noodles775 changed the topic of #launchpad-reviews to: on call: gmb || reviewing: - || queue: [cprov, noodles] || This channel is logged: http://irclogs.ubuntu.com/
=== danilos is now known as Guest95679
noodles775Hi gmb or reviewer - can I pls get a js review for this one when you've time! https://code.edge.launchpad.net/~michael.nelson/launchpad/409187-trivial-ui-fixes-for-p3a-access/+merge/1203513:17
=== danilo__ is now known as danilos
=== bac changed the topic of #launchpad-reviews to: on call: gmb, bac || reviewing: - || queue: [cprov, noodles] || This channel is logged: http://irclogs.ubuntu.com/
=== jtv is now known as jtv-afk
=== bac changed the topic of #launchpad-reviews to: on call: gmb, bac || reviewing: -, noodles || queue: [cprov] || This channel is logged: http://irclogs.ubuntu.com/
=== mup_ is now known as mup
bachi noodles77513:40
=== jtv-afk is now known as jtv
noodles775hi bac!14:23
=== gmb changed the topic of #launchpad-reviews to: on call: gmb, bac || reviewing: cprov, noodles || queue: [] || This channel is logged: http://irclogs.ubuntu.com
bachi noodles775.  i was confused by the MP you submitted.  it looks like it has already been reviewed?  which are the new parts?14:30
noodles775bac: it has, but salgado requested a javascript review (as he didn't feel confident enough). In the mean-time, I added js unittests and a windmill test (in addition to small changes suggested by salgado)14:31
gmbcprov: Do you want me to leave that review to sinzui?14:37
gmbOr am I looking at the wrong branch?14:37
cprovgmb: no, please review it yourself, I will just pass it through curtis if he has time14:38
gmbcprov: Okay, looking now - we are talking about bug-408528-ensurePerson-again, right?14:42
cprovgmb: yup14:42
gmbCool.14:42
cprovgmb: prepare your brain to be melted ...14:43
gmbOh, fun...14:43
bacnoodles775: so is this review a JS review specifically?14:45
noodles775_bac: yep. The rest is already reviewed.14:46
noodles775_bac: but of course, is you see something you think should be improved...14:46
noodles775_s/is/if14:46
bacnoodles775_:  i think i'm going to follow salgado's lead and defer to someone with more JS experience14:46
noodles775_bac: ok, pop it back in the queue... perhaps gmb can have a look (or you guys could swap?)14:47
gmbnoodles775_ I'll try when I've finished with cprov's branch.14:47
gmbIf I have a brain left.14:47
noodles775_heh, ok! Thanks.14:48
gmbcprov: r=me, pending sinzui's approval, too.14:59
cprovgmb: super! I will address Curtis comment. Thanks15:00
noodles775_BjornT: I just wrote our first windmill test using the new layer - you've made writing windmill tests about 100x more fun :)15:01
=== noodles775_ changed the topic of #launchpad-reviews to: on call: gmb, bac || reviewing: cprov, - || queue: [noodles] || This channel is logged: http://irclogs.ubuntu.com
=== gmb changed the topic of #launchpad-reviews to: on call: gmb, bac || reviewing: noodles, - || queue: [] || This channel is logged: http://irclogs.ubuntu.com
gmbnoodles775_: Argh, I'm only just getting to your branch, sorry. Taking a look now.15:37
gmbnoodles775_: |Er... where's the MP; I don't see it on activereviews.15:38
noodles775_gmb: https://code.launchpad.net/~michael.nelson/launchpad/409187-trivial-ui-fixes-for-p3a-access/+merge/1203515:40
noodles775_thanks.15:40
* gmb looks15:41
gmbnoodles775_: Wouldn't it be better to use "if (! Y.Lang.isValue())" than checking for isNull?16:00
gmbOr are you expecting undefineds?16:00
noodles775_gmb: just on a call, I'll be there in a tick.16:00
gmbnoodles775_: Okay, no rush. I'll grab a drink whilst I wait.16:01
noodles775_gmb: hmm, so Y.get returns null if the thing you're trying to get doesn't exist, so Y.Lang.isNull seems more straight forward to me?16:07
noodles775_gmb: in fact, I'd only use !Y.Lang.isValue() if I was expecting undefineds (which I'm not here) right?16:08
gmbnoodles775_: Well, you'd generally use it as a belt-and-braces. If you're not worried about it then fair enough.16:10
gmbJust checking.16:10
adeuringgmb, bac: could you please review this branch: https://code.edge.launchpad.net/~adeuring/launchpad/bug-438734-parse-kernel-release-nnode/+merge/12589 ?16:14
bacadeuring, gmb: i will16:14
adeuringbac: thanks!16:15
=== bac changed the topic of #launchpad-reviews to: on call: gmb, bac || reviewing: noodles, adeuring || queue: [] || This channel is logged: http://irclogs.ubuntu.com
gmbnoodles775_: The comments at the top of the tests should describe the behaviour that the test expects. At the moment they seem to be descriptive of the line the immediately precede.16:16
gmbAlso, some of the tests lack comments.16:16
noodles775_gmb: Yes, I initially had comments there, but then realised that I was duplicating the same string used in the assert?16:17
noodles775_Is there a reason for having that initial comment describing the behaviour the test expects when it's also in the assert output? I wasn't sure.16:18
gmbnoodles775_: Well, I'd change the Assert errors to read more like "X should happen (when Y)" and have the leading comments as "X happens when Y". The comment is for the reader, whereas the Assert message is for the developer who sees a failure (e.g. "X should occur when Y, but it didn't.")16:19
gmbnoodles775_: The advantage of the comments is that you don't have to read the code.16:19
gmb(Unless you want to)16:19
noodles775_gmb: ok - it seems like duplicating (virtually) the same info, but I can do that :)16:20
gmbnoodles775_: Two different sets of stakeholders. The person reading the test failures isn't neccessarily the same person who's looking at the code. And the person who's looking at the code doesn't want to parse it when he doesn't have to.16:21
gmbEspecially if that person is me.16:21
noodles775_gmb: yep, np. I personally just don't see it as any easier to parse the comment than the assertion string in such small tests, but consider it done :)16:21
gmbnoodles775_: Cool.16:22
gmbnoodles775_: Other than that, r=me.16:22
noodles775_Great, thanks!16:22
* gmb goes off review so that he can catch up on other work.16:22
=== gmb changed the topic of #launchpad-reviews to: on call: bac || reviewing: adeuring || queue: [] || This channel is logged: http://irclogs.ubuntu.com
bacadeuring: done16:26
bacbye gmb16:26
adeuringbac: thanks!16:26
=== bac changed the topic of #launchpad-reviews to: on call: bac || reviewing: - || queue: [] || This channel is logged: http://irclogs.ubuntu.com
=== matsubara is now known as matsubara-lunch
allenapbac: Got time to review a tiny change? https://code.edge.launchpad.net/~allenap/launchpad/ec2-niceties/+merge/1259316:55
bacallenap: yep16:56
allenapbac: Thanks.16:56
bacallenap: no, thank you!  i look forward to a quieter ec2 experience16:56
bacallenap: hey, while i have you held hostage, did you see my bug about buildbot and UTC?16:57
bacallenap: r=bac, btw16:57
allenapbac: Thanks :)16:57
bacallenap: gah, does this mean you're ignoring me?16:58
allenapbac: I think I did, but I can't remember it now.16:58
allenapbac: Of course I'm not ignoring you :) I'm just taking a long time.16:58
bacok, well when you have a chance to look into it i'd be curious to know if it is doable/easy.16:58
bacmy head  almost exploded last week in a call trying to juggle UTC, BST, and EST16:59
allenapbac: BST is easy for me ;)17:01
bacallenap: cool, i'll nominate you for release manager17:02
allenapbac: Actually, I'll start work on this bug soon. It seems like a good place for me to get into buildbot.17:02
allenapbac: On second thoughts....17:02
BjornTbac: can you do a quick review of this? https://code.edge.launchpad.net/~bjornt/launchpad/windmill-1.3beta/+merge/1260118:21
bacsure BjornT18:21
=== bac changed the topic of #launchpad-reviews to: on call: bac || reviewing: bjornt || queue: [] || This channel is logged: http://irclogs.ubuntu.com
BjornTbac: i did this change just now to clarify things further: http://pastebin.ubuntu.com/281491/18:24
bacBjornT: i'm a little confused.  where will it find that version of windmill?18:25
BjornTbac: in download-cache. i've already added it there, so you can test it if you want18:26
bacBjornT: ah, right.  (lightbulb goes off)18:26
bacBjornT: this looks good to me.18:27
BjornTthanks18:27
=== EdwinGrubbs is now known as Edwin-lunch
al-maisanhello bac, how are things?18:46
bachi al-maisan18:46
=== bac changed the topic of #launchpad-reviews to: on call: bac || reviewing: - || queue: [] || This channel is logged: http://irclogs.ubuntu.com
al-maisanCould you please review a branch of mine?18:47
bacal-maisan: sure.18:47
al-maisanIt's here: https://code.edge.launchpad.net/~al-maisan/launchpad/unembargo-email-316488/+merge/1260318:47
al-maisanbac: thanks18:47
bacal-maisan: i'll get on it shortly when the diff arrives18:48
al-maisanbac: thanks, that's fine :)18:48
al-maisanhmm .. the diff calculation for merge proposals seems not to be working correctly ..18:53
al-maisanbac: the actual diff is here: https://pastebin.canonical.com/22758/18:53
bacthanks muharem19:09
bacal-maisan: i wonder why the diff is different.  did you target the wrong branch?19:10
al-maisanbac: maybe19:13
al-maisanI branched from devel19:13
al-maisanshould I be branching off db-devel ?19:13
bacal-maisan: no, devel is right, AFAIK19:14
bacal-maisan: please use paste.ubuntu.com so everyone has access.19:18
bacal-maisan the code changes look great.  thanks for the nice branch.19:19
al-maisanbac: thanks :)19:20
al-maisanwill use paste.ubuntu.com in future19:20
=== Edwin-lunch is now known as EdwinGrubbs
leonardrbac, can you review this lazr.restfulclient branch?20:36
leonardrhttps://code.edge.launchpad.net/~leonardr/lazr.restfulclient/basic-auth/+merge/1261220:36
bacleonardr: sure20:36
bacleonardr: why is that branch private?20:37
leonardrnot intentionally20:37
baci figured not.  odd.20:37
leonardryou should be able to see it now20:37
bacleonardr: i can see it but was curious about the hash marks on the left, the privacy indicator20:38
bacleonardr: on the MP i mean20:38
leonardrmaybe that project's branches are private by default20:39
bacleonardr: the default policy is public but branches by ~launchpad are private.  i think that should be changed unless there's a good reason20:40
bacnice job leonardr.  r=bac20:48
leonardrgreat20:48
bachi barry, are you really here?20:48
barrybac: kinda sorta20:51
barrybac: what's up?20:52
bacbarry: not much.  just seeing if you are alive20:52
barrybac: ibuprofen is a wonderdrug20:52
=== bac changed the topic of #launchpad-reviews to: on call: - || reviewing: - || queue: [] || This channel is logged: http://irclogs.ubuntu.com
=== matsubara is now known as matsubara-afk

Generated by irclog2html.py 2.7 by Marius Gedminas - find it at mg.pov.lt!