/srv/irclogs.ubuntu.com/2009/10/07/#launchpad-meeting.txt

=== mrevell is now known as mrevell-lunch
=== mrevell-lunch is now known as mrevell
barry#startmeeting15:00
MootBotMeeting started at 09:00. The chair is barry.15:00
MootBotCommands Available: [TOPIC], [IDEA], [ACTION], [AGREED], [LINK], [VOTE]15:00
barryhello everyone and welcome to this week's ameu reviewer's meeting.  who's here today?15:00
sinzuime15:00
EdwinGrubbsme15:00
intellectronicame15:00
flacosteme15:00
bacme15:00
deryckme15:00
noodles775me15:00
barrygary_poster danilos bigjools allenap jml BjornT ping15:01
bigjoolshi15:02
allenapme, sorry15:02
gary_posterme15:02
barry[TOPIC] agenda15:02
* bigjools stabs Google calendar15:02
MootBotNew Topic:  agenda15:02
barry * Roll call15:02
barry * Action items15:02
barry * UI review call update15:02
barry * Careful with those drive-bys, they make reviewing unnecessarily harder [intellectronica]15:02
barry   * How can we better incorporate drive-bys and other tech debt payoff into our development process? [barry]15:02
barry * Noodles and I (Edwin) discovered that we were using different guidelines for what goes into the view.label property.15:02
danilosbarry, in a sprint, won't be joining you (as will nobody from translations team), sorry15:02
barry   * My method reduces the amount of redundancy between the <h1> and the breadcrumbs directly below it. For example:15:02
barry     || '''Define upstream link''' <<BR>> Ubuntu >> 9.04 >> “mozilla-firefox” source package >> Define upstream link ||15:02
barry   * Noodle's method could have better google foo, since it puts more relevant info in the <h1>. For example:15:02
barry     || '''Define upstream link for mozilla-firefox in Ubuntu Jaunty''' <<BR>> Ubuntu >> 9.04 >> “mozilla-firefox” source package >> Define upstream link ||15:02
barry * Peanut gallery (anything not on the agenda)15:02
barry 15:02
barry 15:02
barrydanilos: cool, thanks15:02
abentleyme15:02
barry[TOPIC] action items15:02
MootBotNew Topic:  action items15:02
danilos+1 on barries method of view.label definition :)15:03
danilosuhm, "barry's" :)15:03
* danilos goes back to sprinting15:03
jmlbarry, hi15:03
barryas long as it's not berries :)15:03
barryjml: hi!15:03
BjornTme15:03
barry * gary_poster and barry will transfer review guidelines from the old wiki and old old wiki to the new wiki15:03
barrywe still suck15:03
gary_posteroh we do!  It had been so long that I had forgotten I suck!15:04
barrygary_poster: maybe we should admit defeat15:04
gary_posterlol15:04
gary_posterbarry: we almost had Matt doing it15:04
gary_posterbarry: we just needed to tell him...something15:04
gary_posterbarry: I tried to do it but no longer had access for some reason15:04
barrygary_poster: right!  i'll ping him on it and see if he can help out15:04
gary_posterbarry: cool15:04
barry[TOPIC]  * UI review call update15:05
MootBotNew Topic:   * UI review call update15:05
gary_posteraction: barry to get matt to do the work he and gary were going to do ;-)15:05
barry:)15:05
barryi wonder if beuno is around?15:05
barryintellectronica: can you give a quick summary of the meeting?15:05
intellectronicasure15:05
intellectronicatwo interesting items:15:05
intellectronica1. martin will start working with one or two ui reviewers towards graduating them15:06
intellectronicaas part of the process they will hopefully start collecting documentation of complete reviews15:06
intellectronica2. there's some concern about the timing of the upgrade to the latest version of YUI315:07
intellectronicaideally, we'd like to have that before the next LAZR-JS sprint, so that whatever we do there builds on the new codebase, but it's unclear whether that's realistic given the resources we have for that time15:07
sinzuiDoes everyone know that beuno is writing the Web UI guidelines for all Canonical. He is using Launchpad as the basis, but when finalised, we may need to make changes.15:08
intellectronicaindeed15:08
intellectronicafinally, now that some ui reviewers will graduate, reviewers are welcome to join as mentees. talk to martin if you're interested15:08
barryhi beuno !  intellectronica gave a good summary of the meeting.  do you have an eta for ui reviewer graduations?15:09
flacosteintellectronica: regarding 2.15:09
flacostegary scheduled that for this cycle when Maris comes back15:09
flacostewith help from salgado15:09
intellectronicaawesome!15:09
flacosteso we should have lazr-js updated by the sprint15:10
beunoI've talked to Gary about upgrading YUI3 before the sprint15:10
flacostealso, Bjorn is finishing the buildout migration to lazr-js15:10
gary_posteryes15:10
flacostewhich will allow us to upgrade lazr-js to YUI3 without affecting LP15:10
gary_posteryeah those are the key bits.15:10
gary_posterThen the sprint would be able to work on migrating Launchpad itself to YUI 3 and the new lazr-js15:11
gary_poster(in part)15:11
barrygary_poster, beuno can we also spend time on making it easier to add js to launchpad?  it's still a very painful process :/15:11
intellectronicagary_poster: in the ui call, we discussed how that might not be the best use of sprint time15:12
beunobarry, we will have 7 people from other teams, we *need* to make it easier15:12
intellectronicamaybe this is the wrong meeting for dicussing this stuff, though15:12
barrybeuno: great.  i really think this is critical for our success here15:12
barryintellectronica: true.15:12
gary_posterintellectronica: yeah maybe so :-) but ok, then we migrate Launchpad after the sprint15:13
intellectronica:)15:13
barryso.  intellectronica, beuno anything else re: the ui meeting this week?15:13
beunoI will be working with noodles77515:13
gary_posterbarry, beuno, that's a discussion to have with BjornT also I suspect.15:13
beunoto graduate him, so please send UI reviews his and my way these next 2 weeks15:13
barrygary_poster: good pint15:13
abentleyintellectronica, beuno: I heard something about a new requirement to report ui work?15:13
intellectronicareport?15:14
beunoreport?15:14
gary_posterreport?  (just helping out)15:14
abentleyrockstar said something about us having to report when we were doing ui work.15:14
intellectronicareport to whom, and in what format?15:14
abentleyintellectronica: Report at a new meeting, IIRC.15:14
beunoI asked rockstar what your team was up to, that's all15:14
intellectronicai've never heard of this before15:15
abentleybeuno, intellectronica: maybe I got it wrong.  I'll ask him.15:15
intellectronicaah ok, yes. in general we like to have a status round in those meetings so it's good if the team's representative knows the status of ui work for the week15:15
barryintellectronica, beuno thanks.  let's move on...15:16
beunobarry, did you get that about noodles775?15:16
barrybeuno: noodles775 is going to graduate, right?15:17
barrybeuno: or has he already graduated?15:17
noodles775will start the process :)15:17
barrynoodles775: fantastic15:17
beunobarry, I'm going to work with him these next 2 weeks, so please throw as many UI reviews at him as you can, and add me as well  :)15:17
barry[AGREED] send your ui reviews to noodles775 and beuno so noodles775 can get graduated15:17
beuno(within reason)15:17
MootBotAGREED received:  send your ui reviews to noodles775 and beuno so noodles775 can get graduated15:17
barry[TOPIC] drive-byes15:18
MootBotNew Topic:  drive-byes15:18
barry * Careful with those drive-bys, they make reviewing unnecessarily harder [intellectronica]15:18
barry   * How can we better incorporate drive-bys and other tech debt payoff into our development process? [barry]15:18
barry 15:18
barryintellectronica: do you want to start?15:18
intellectronicasure15:18
intellectronicaso, traditionally, we've encouraged people to do drive-by cleanups when working on unrelated branches15:19
intellectronicabut in reviews, i find that these cleanups actually make the review much less focused15:19
intellectronicafrom a review pov, it would actually be much better if there were no unrelated cleanups in a branch15:20
intellectronicaso there's a trade-off here, and i wonder how to best get the right balanace15:20
barryintellectronica: it's a great point.  i'm guilty of that.  and yet, how do we encourage more cleanups and tech debt payoff?15:21
barrywhat do people think about trying an experiment?15:21
abentleyintellectronica: IME, bzr has the opposite problem, because it wants to avoid spurious changes.15:21
intellectronicathat's on the assumption that drive-by cleanups are in general a good thing. that's also something we should maybe re-examine15:21
sinzuiI favor landing drvie-bys in a first branch15:21
barrywhere we rs pure drive-by branches?15:21
intellectronicaabentley: yes, i think avoiding spurious change is actually a desirable15:21
gary_posterThere's a silly but real issue:15:22
intellectronicabarry: so, we used to have that policy, and i think it got shot down for fear of abuse15:22
gary_posterI usually set my editors to remove trailing whitespace15:22
barryintellectronica: but was that fear warranted?15:22
gary_posterI usually like this15:22
abentleyusing pipeline or loom makes it easy to do drive-bys in a separate branch, then land the drive-by and the real branch at the same time.15:22
gary_posterAnd I usually don't notice this15:22
gary_posterBecause it is automatic15:22
gary_posterAnd happens when I do work on something else15:23
intellectronicagary_poster: i think that's acceptable exception15:23
gary_postercool15:23
barrygary_poster: i think that's the real issue for me.  drive-byes are exactly that.  you're working on something and you see something you could easily clean up right then and there.  looms/pipelines help, but not completely15:23
bacabentley: so do you submit a drive-by diff after your main review?15:24
intellectronicabarry: but is that really a good thing to do? it is of course great to improve the codebase in general, but from the perspective of the branch you're working on, is the unrelated change really an improvement?15:24
abentleybac: In this hypothetical, you'd submit them both at the same time, and then land the last pipe / top thread.15:24
abentleybac: after both had been approved.15:25
gary_posterI think pipelines will make it easier for me to do the non-whitespace cleanups15:25
barryintellectronica: that's a great point, however i think if you don't jfdi then, it'll almost never happen.  maybe it's okay it never happens, but it seems like a wasted opportunity15:25
gary_postereasier to do separately, I mean15:26
intellectronicabarry: honestly, i am undecided about that, but i surprised myself by thinking that there's at all a dilemma. maybe drive-bys aren't such an important thing after all15:26
barryintellectronica: i'm not quite willing to go that far yet :)15:27
intellectronicain a way, drive-bys are unscheduled work which you're doing at the (marginal) expense of more important work15:27
gary_poster(the team lead meeting did celebrate the idea of "slack": time spent on tech debt both opportunistically and scheduled)15:28
abentleyintellectronica: If you look at it that way, it's easy to build up technical debt.15:28
barryabentley: exactly, because such low priority issues are never scheduled15:29
intellectronicaabentley: au contraire. it forces you to schedule technical debt payments15:29
barryintellectronica: but in practice...?15:29
BjornTbarry: how about always having a clean up-to-date branch. when see something that needs fixing, do the fix in the clean branch, get a quick review (showing a diff to the reviewer is enough), and merge it right-away?15:29
abentleyintellectronica: Perhaps we don't really disagree-- I thought you were saying that debt reduction was less important than other work.15:29
bigjoolspink.bikeshed.com15:29
BjornTbarry: that's way i always do, except that i generally create the new branch from scratch, since it's quick to do so.15:30
intellectronicaBjornT: yes, i think that's a good way to do it15:30
barryBjornT: hmm.  sort of always having a tech debt branch laying around when you're working on the real bug.  clean things ujup there instead of your real branch?15:30
intellectronicabigjools: we don't have to discuss tech debt and so on in detail. what i'd like is to get out of this meeting with a recommendation that people don't do unrelated drive-bys in the same branch15:31
BjornTbarry: yeah. you probably don't even to have that branch laying around, you can create it when you need it.15:31
bigjoolsintellectronica: I think common sense should mostly prevail and if it's a simple one-liner then do it, otherwise leave it for a separate branch.15:32
barryBjornT: i have stupid reasons why that might not work as well for me, but i'm going to think about it, and especially wrt to pipelines/looms15:32
BjornTbarry: i think the key here is that the review should be quick; the reviewers should give priority to drive-by diffs maybe.15:33
intellectronicabigjools: true. but i've seen branches that are a third drive-by15:33
barryintellectronica: i'm okay with that if we still find ways to encourage cleanups and other tech debt payments.  BjornT's idea, schedule slack, might hep15:33
sinzuiI often shelve the unwanted changes and unshelve in a new branch.15:33
abentleysinzui: You mean "bzr shelve; bzr switch; bzr unshelve" ?15:34
intellectronicabarry: we could, like BjornT suggested, prioritize these reviews higher, or offer to review two branches one after the other if the developer went out of his way to do some cleanup work in another branch15:34
BjornTbarry: another thing i do frequently is to do the fix in the branch i'm working on, but then i merge that commit into a seperate branch, which i submit for review while working on completing the first branch15:34
barryintellectronica, BjornT i think those are both great ideas15:35
sinzuiabently no, I am idiot. That sounds like what I want to do. I have been moving the shelve to the new branch15:35
barryintellectronica: why don't you and i spend some time outside this meeting to formulate some guidelines and perhaps run an experiment?15:35
intellectronicabarry: works for me15:36
barry[ACTION] intellectronica and barry to formulate guidelines/run an experiment for improving drive-by/tech debt payment15:36
MootBotACTION received:  intellectronica and barry to formulate guidelines/run an experiment for improving drive-by/tech debt payment15:36
barry[TOPIC] * Noodles and I (Edwin) discovered that we were using different guidelines for what goes into the view.label property.15:36
barry 15:36
MootBotNew Topic:  * Noodles and I (Edwin) discovered that we were using different guidelines for what goes into the view.label property.15:36
noodles775barry: I sent an email out a few hours ago to lp-dev... so far it looks like the low-redundancy version that Edwin used is favoured :)15:37
barrynoodles775, EdwinGrubbs the floor is yours15:37
sinzuibarry: This is a chance for you to formalise you trivial experiment15:37
barrynoodles775: i way behind on my email today :(15:37
barrysinzui: +1 :)15:37
noodles775and danilos, the second option actually originated from a review of I did of translations pages (for jtv I think). I don't remember the page in the review, but here's an example:15:37
noodles775https://translations.edge.launchpad.net/~danilo/+imports15:37
noodles775With the first option the h1 would be 'Import queue'.15:37
noodles775So barry, it might be worth discussing next week anyway (and end this meeting more quickly) ;)15:38
EdwinGrubbsThe main question is whether information is duplicated in the <h1> and the breadcrumbs, since the <h1> should give us better google juice.15:38
EdwinGrubbsnext week is fine15:38
barrynoodles775: sounds good!15:38
barry[TOPIC] peanut gallery15:38
MootBotNew Topic:  peanut gallery15:38
danilosnoodles775, I still think it's nicer, +imports pages are a special case because they live on many contexts (product, distro, distroseries, person, sourcepackage), so it's hard to get them right15:39
barrywe have 7 minutes left.  does anybody have anything not on the agenda?15:39
danilosanyway, left for next week when I hope I can participate, sorry for interruptions :)15:39
barry515:39
barry415:40
barry315:40
barry215:40
barry115:40
barry#endmeeting15:40
MootBotMeeting finished at 09:40.15:40
barrythanks everyone!15:40
abentleyThanks barry.15:40
gary_posterthank you barry15:40
noodles775Thanks barry!15:40
=== gary_poster is now known as gary-phone
=== EdwinGrubbs is now known as Edwin-afk
=== gary-phone is now known as gary_poster
barry#startmeeting21:33
MootBotMeeting started at 15:33. The chair is barry.21:33
MootBotCommands Available: [TOPIC], [IDEA], [ACTION], [AGREED], [LINK], [VOTE]21:33
mwhudsonhi21:34
rockstarni!21:34
barryhi!21:34
barrywelcome to our new earlier time21:34
barryi guess i'll start with a review of ameu21:34
barry * barry will ask mrevell for help in converting the old wiki guidelines to the new dev wiki21:35
barry * beuno will work with noodles to get him ui graduated.   for the next 2 weeks, please send most of your ui reviews to them21:35
barry * talk to beuno if you're interested in becoming a ui mentat21:35
barry * intellectronica and barry will work out some guidelines for drive-by and tech debt payoff branches (contemporaneous drive-byes considered harmful)21:35
barry(and we had some strategies to look at for improving drive-bys and tech debt)21:35
barrythat's it. is there anything you'd like to talk about?21:35
barryrockstar, mwhudson ?21:37
mwhudsoni think the last bullet could use expansion21:37
mwhudson"contemporaneous drive-byes considered harmful"21:37
mwhudson?21:37
barrymwhudson: so, intellectronica pointed out how distracting drive-bys can be when reviewing a branch.  i think he observed one branch where 1/3 of the code change was tech debt.  hard to pick out the important stuff21:38
mwhudsonoh right yes21:38
barryintellectronica even questioned whether drive-bys and the value they bring are worth the effort21:38
barryi think they still are, so it's finding the right way to do them21:39
barrysome ideas:21:39
barry* use bzr looms/pipelines to segregate the cleanups21:39
mwhudsoni think the cost of drive-bys to a review depends on how "easy" the review is21:39
barry* use some of the schedule slack to do pure tech debt branches21:39
barry(etc.)21:39
mwhudsonif it's a simple change to code you and the coder know well, it's no big deal21:39
barrymwhudson: i usually don't mind them21:40
barryi guess my goal is to make it even easier than it is now to clean up our code21:41
barryhow can we do that while not making reviewer lives hell?21:42
barrymwhudson, rockstar any other thoughts for today?21:43
rockstarbarry, not from me.21:43
barrymwhudson: ?21:44
mwhudsonoops, got taken away sorry21:44
mwhudsonnothing more from me21:44
mwhudsonbarry: apart from21:45
barrycool.21:45
barry...21:45
mwhudsoni totally support effort to keep a clean code base21:45
mwhudsonit's worth a lot, possibly more than one realises21:45
mwhudson.21:45
barrymwhudson: i completely agree!  thanks21:45
barry#endmeeting21:45
MootBotMeeting finished at 15:45.21:45

Generated by irclog2html.py 2.7 by Marius Gedminas - find it at mg.pov.lt!