[02:43] thumper, ping. [02:43] rockstar: hey hey [02:44] thumper, unping. I need to check to make sure my assertion is correct before making it. [03:47] thumper, NOW I think I'm ready to land this branch. I've taken out the tree creation (at one point I was running the job, so it needed a tree) [03:48] rockstar: is it pushed? [03:49] thumper, yessir. A bit ago (I got distracted) [03:52] rockstar: https://code.launchpad.net/~thumper/launchpad/more-product-series-permissions/+merge/16888 [03:53] thumper, wait, I have to scratch your back for to scratch mine? :) [03:53] rockstar: you don't *have* to... [03:54] thumper, I'm kidding. Looking now. [03:54] thumper, so this allows us to delete import branches that are the series branch? [03:55] rockstar: yes [03:55] Awesomeness. [03:55] rockstar: now I have a few questions [03:55] thumper, shoot. [03:55] rockstar: why create two branches in the test? [03:55] rockstar: if you are only testing that newer ones aren't deleted, you don't need two branches [03:55] branch jobs [03:56] just one [03:56] is enough [03:56] Hm, okay. [03:56] then you can remove the first assert [03:56] also why use transaction.commit() [03:56] is that really necessary> [03:56] ? [03:56] you have no comment at the top of the test [03:56] you have two lines between the tests [03:56] thumper, yes, otherwise it blows up apparently. [03:56] and I don't think you need tempfile anymore [03:56] apparently or certainly? [03:57] thumper, it was blowing up otherwise. [03:57] with what error? [03:57] I don't see why you should need the commit [03:58] thumper, lemme try. [04:02] mwhudson: https://code.edge.launchpad.net/~thumper/launchpad/revision-karma-fix/+merge/16890 [04:08] mwhudson: ta, using critical [04:22] thumper, yea, looks like the transaction.commit is needed. [04:23] rockstar: hmm [04:23] ok [04:23] rockstar: have you fixed the other bits? [04:23] thumper, no idea, but the other tests in the TestCase do it as well. [04:24] thumper, other bits fixed, pushing now. [04:24] ok [04:29] thumper, diff is updated. [04:34] rockstar: replied, a few more things to fix [04:42] thumper, I think I got them all this time. [04:43] * rockstar REALLY wants to send this branch off the ec2 [04:47] thumper, going home from the coffee shop, back soon (hopefully to submit to PQM) [04:47] ok [04:48] rockstar: you are good to go now [05:01] thumper, sweet, thanks. === jtv changed the topic of #launchpad-reviews to: on-call: jtv || reviewing: - || queue [] || This channel is logged: http://irclogs.ubuntu.com || https://code.edge.launchpad.net/launchpad/+activereviews === jtv is now known as jtv-afk === stub1 is now known as stub === jtv-afk is now known as jtv [10:29] stub: I followed up on your db review yesterday... is it enough to take you from Needs Information to Approved? [10:44] jtv: updated [10:44] ta === salgado-afk is now known as salgado === matsubara-afk is now known as matsubara [11:58] hello jtv, are you still reviewing? [11:58] al-maisan: indeed! [11:58] Great! Would you mind taking a look at https://code.edge.launchpad.net/~al-maisan/launchpad/xx-next-builder-502927/+merge/16896 ? [11:58] gimme [11:58] looking... [11:58] thanks :) [11:59] oh nice... will this one also generalize BuildQueue.required_build_behavior? [11:59] seems no... but progress is progress :) [12:00] jtv: not really .. this is still about job dispatch time estimation [12:00] step n-3 [12:00] Oh, I see you got builder_key un-nested... I like it better this way [12:00] (but didn't say anything last time because IIRC you had nested it based on another reviewer's suggestion) [12:01] yes, it was jml's suggestion I believe [12:01] now builder_key() is used in more than one place [12:01] damn his morning croissant [12:02] .. and the crumbles :) [12:02] But where is _minTimeToNextBuilderAvailable actually called? [12:02] jtv: nowhere yet [12:02] (tests aside, of course) [12:02] that will come in one of the next branches [12:02] OK [12:03] Then bear in mind that a method name should begin with a verb [12:03] the branch this is taken from is almost 2K LOC [12:03] ah .. a verb [12:03] maybe "estimate"? [12:03] I can fix that [12:03] "estimate" is nice .. I like that. [12:03] instead of "min" (because the docstring suggests this is an estimated time, not a mininum) [12:04] good idea! [12:04] Also, "Get" is one of those over-generic and over-used words... Why say "Get estimated time" when you're really producing one? Same verb can serve there. :-) [12:05] hmm .. fair enough. [12:05] Also, mixed_mode is a bit cryptic. Can you document it in the docstring? [12:06] jtv: I can but the big comment at the beginning of the method is all about the "mixed mode" [12:07] al-maisan: I look at the comments when I want to know more about the implementation, but the docstring should give me the "This Method for Dummies" meaning of the parameter. [12:08] How about processor_dependent? [12:08] or even, is_processor_specific? [12:09] As the law goes, two things are hard in computer science: cache invalidation and naming things. [12:10] jtv: I can add the explanation in the doc string. [12:11] .. and yeah, naming things is not easy, I agree :) [12:11] "mixed_mode" really expresses the meaning best IMHO [12:11] think about a queue with jobs [12:12] what this method needs to know is whether there are jobs ahead of the job of interest (JOI) that are processor independent [12:12] if yes, then all builders should be considered [12:13] isn't that "mode" a property of the BuildQueue object? [12:13] jtv: not quite each job has a BuildQueue [12:14] Right, that's why I'm asking. [12:14] BuildQueue should actually be named BuildQueueJob [12:14] The BuildQueue's job can be architecture-specific or non-architecture specific... isn't that what determines which value will be passed here? [12:15] what is being passed in here is: are there any jobs ahead of me that are processor independent? [12:15] ahead of me in the sense that they have a higher score and .. [12:15] .. should be dispatched before me [12:16] me being the build queue job of interest [12:17] al-maisan: maybe it would help me to understand why you need the two "modes." Are you trying to get an estimate of when this particular job can start running (assuming that it's at a front of the queue)? [12:18] again, think of a queue of jobs [12:19] jtv: please give me few minutes to come up with a clarifying example [12:20] al-maisan: it would help me a lot right now to have an idea of what this method will be used for [12:20] OK [12:21] the question this method answers is: what is the shorted time until a builder capable of running the JOI becomes available? [12:22] jtv: s/shorted/shortest/ [12:22] but then my previous question stands: isn't whether the job is architecture-dependent or not a property of the BuildQueue object (or its associated Job etc.)? [12:23] yes, that's what's encoded in the 'my_processor' local variable [12:23] but [12:24] there's (at least) one other scenario where that is not sufficient [12:25] job queue [amd_job_1, proc_independent_job_2, x86_job_3, x86_job_4] [12:25] let's assume x86_job_4 is the JOI [12:26] in that case proc_independent_job_2 and x86_job_3 compete for its builder pool [12:26] but not amd_job_1 [12:28] so, what I need to know is: how long is the delay until the head of the queue of mutually competing jobs can be dispatched [12:29] (btw otp sorry) [12:30] jtv: actually, I just realized that the method may not be doing what it's supposed to do. [12:30] jtv: please ignore this merge proposal until I come back to you. === mrevell is now known as mrevell-lunch [12:42] * jtv finally gets off phone [12:42] al-maisan: the entire MP? And we were still on the first line of diff! [12:43] new record for me ;-) [12:43] jtv: you are asking good questions :) [12:44] "I could tell from the way his first two characters rendered in my browser that there was a bug somewhere" [12:44] meanwhile, I'll go have a standup :) [12:44] jtv: thanks for looking at this anyway :) [12:44] no worries, it's what we're working on! === mrevell-lunch is now known as mrevell [14:11] hello gmb, I know it's not your OCR day but I have a branch that needs to land today. Would you be in a position to take a look at it? It's 611 lines long but the bulk of it are tests. [14:12] here's the diff: http://pastebin.ubuntu.com/352336/ [14:13] al-maisan: Sure. [14:13] al-maisan: Is there a merge-proposal for this? [14:13] gmb: I really appreciate your help .. the MP is here: https://code.edge.launchpad.net/~al-maisan/launchpad/xx-next-builder-502927/+merge/16896 [14:14] al-maisan: No worries :). I'll grab a cup of tea and then take a look. [14:14] gmb: if you want to go through examples, I have a picture of some scenarios here: https://devpad.canonical.com/~muharem/IMG_0275.JPG [14:14] al-maisan: Thanks. [14:17] we can also have a voice call .. whatever suits you. [14:28] al-maisan: Bear with me; I'll ping you when I need more information :) [14:29] gmb: great :) === salgado is now known as salgado-lunch === abentley changed the topic of #launchpad-reviews to: on-call: jtv || reviewing: - || queue [abentley] || This channel is logged: http://irclogs.ubuntu.com || https://code.edge.launchpad.net/launchpad/+activereviews === fjlacoste is now known as flacoste [15:21] al-maisan: So, what happens if our 120 second wild guess is wrong? Anything bad? [15:21] gmb: not really .. the estimate will not be as good as we'd like. [15:22] the dispatch time estimate that is [15:22] al-maisan: Okay, cool. I think that the comment in the SQL should be updated to reflect that it's not going to make horrible things happen. [15:22] gmb: fair enough, can do that. [15:35] al-maisan: Very impressive branch. r=me with the comment change and one other minor nitpick (see review) [15:35] gmb: thanks a million! I owe you one :) [15:35] :) === matsubara is now known as matsubara-lunch === salgado-lunch is now known as salgado === EdwinGrubbs changed the topic of #launchpad-reviews to: on-call: jtv, Edwin || reviewing: - || queue [abentley] || This channel is logged: http://irclogs.ubuntu.com || https://code.edge.launchpad.net/launchpad/+activereviews === beuno is now known as beuno-lunch [16:08] EdwinGrubbs: Could you please review https://code.edge.launchpad.net/~abentley/launchpad/no-review-diff/+merge/16900 ? [16:09] abentley: sure [16:09] EdwinGrubbs: Thanks. [16:09] EdwinGrubbs: jtv is listed in the topic, but apparently has connectivity issues. [16:16] flacoste, i'm getting somewhat close to being able to land the first major multiversion branch. i wonder if you're interested in going over it with me. it would be a fairly major project (i have divided it into two chunks but each chunk is larger than 800 lines) [16:16] (ie. i am trying to find someone to do a review, and i thought of you since you're interested in this project) [16:17] leonardr: yes, i'd have time for this this afternoon [16:17] flacoste, ok, great === beuno-lunch is now known as beuno [17:02] abentley the docstring for test_preview_diff_text_with_no_diff() says that the review_diff should be None when there is no context.preview_diff. Is that right? I don't really understand the difference between a review diff and a preview diff or whether all the objects treat them as separate. [17:03] EdwinGrubbs: The confusion between review diffs and preview diffs was one of the reasons we got rid of review diffs. A review diff shows the changes the branch author made. A preview diff shows what would happen if you merged that branch. [17:04] EdwinGrubbs: The review_diff field on the view class now actually refers to the preview diff, so the docstring is accurate. [17:05] abentley: is that first docstring in the diff correct, or should "review_diff" be "preview_diff". In the test you are checking view.preview_diff_text. [17:06] EdwinGrubbs: I think review_diff should be preview_diff_text. [17:06] abentley: The docstring for test_preview_diff_utf8 doesn't make any sense. [17:07] EdwinGrubbs: It means that if the bytes are utf-8-encoded, they should be decoded to unicode as utf-8. [17:08] abentley: can you clarify that in the docstring? [17:08] EdwinGrubbs: "A preview_diff in utf-8 should be decoded as utf-8" ? [17:13] abentley: yes, but there is no reason to say utf-8 twice, can you say "decoded into a unicode object"? [17:14] EdwinGrubbs: The reason to say it twice is because it should not be decoded using a different encoding. [17:14] e.g. "A preview_diff in utf-8 should be decoded as utf-8, not utf-16" [17:15] abentley: ok, that makes sense, since that's what you are really trying to test. [17:18] abentley: in xx-branch-merge-proposals.txt, a tag with id='review-diff' is retrieved. Is that just a case where the UI hasn't yet been updated to match the name of the attribute that is now used? [17:19] EdwinGrubbs: Yes. [17:19] r=me with the two docstring changes [17:19] EdwinGrubbs: Thanks. === matsubara-lunch is now known as matsubara === EdwinGrubbs is now known as Edwin-lunch [17:44] flacoste, let me know when you're ready to start the review [17:44] send it to me, i'll start on it after lunch [17:45] ok, the first bit is some code i pushed back in november [17:45] https://code.edge.launchpad.net/~leonardr/lazr.restful/version-specific-request-interface/+merge/15172 [17:45] i'm working on writing up the subsequent changes [17:45] i tried to use looms for this branch but i didn't do a very good job [17:45] on top of that branch, i've got one tiny thread and one enormous thread [17:50] leonardr: i'll look at that m-p after lunch and contact you if i have any questions [17:56] ok [17:56] then we'll move from there === flacoste is now known as flacoste_lunch === deryck is now known as deryck[lunch] === flacoste_lunch is now known as flacoste === Edwin-lunch is now known as EdwinGrubbs === matsubara is now known as matsubara-afk === deryck[lunch] is now known as deryck === noodles76 is now known as noodles775 [20:07] EdwinGrubbs: can I have r=you for adding a top-level .ctags to the launchpad tree? [20:08] flacoste: sure [20:08] flacoste: thanks for doing that [20:27] leonardr: around? [20:27] flacoste, yes [20:27] leonardr: do you remember why in multiversion.txt you have to register an IComponentLookup adapter? [20:28] everything_uses_the_global_site_manager [20:28] flacoste: i was modeling it after webservice.txt. i assumed it was because the test was running in a very minimal environment [20:28] i'll try removing it and seeing if it still works [20:29] flacoste, that code is unnecessary both in webservice.txt and multiversion.txt. i'l remove it from both places [20:29] leonardr: ok, thanks! [20:32] leonardr: what is the use of IVersionedClientRequestImplementation [20:32] ? [20:32] I'm reading the "Defining the request interfaces" section [20:33] and the narrative doesn't talk about that interface [20:33] flacoste: IVCRI makes it easy to look up a marker interface based on the version string [20:33] leonardr: ok, you probably want to explain that in the narrative then [20:33] sure [20:51] leonardr: first review done [20:51] flacoste, ok [20:52] because the original branch causes a huge number of test failures (the second branch is all about fixing these), i'm going to make your suggested changes to the second branch [20:53] leonardr: ok, i won't have time to review the second branch today though [20:53] flacoste: no problem [20:54] i'm almost done for the day. i'll spend the rest of the day responding to your review and we can pick up tomorrow [20:55] flacoste: not sure why those conflict markers are showing up [20:55] i'll re-push my branch and hopefully they'll disappear [20:56] leonardr: branch trunk and merge your branch [20:56] see if you get any conflicts [21:05] nope === Ursinha is now known as Ursinha-afk