/srv/irclogs.ubuntu.com/2010/11/25/#launchpad-reviews.txt

=== jtv changed the topic of #launchpad-reviews to: On call: - || Reviewing: None || queue = [henninge, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
jtvSince this is the reviewers channel… if we're going to write the queue in the topic in python, how do I make it follow our coding standards?06:11
StevenKSubmit a patch06:15
=== StevenK changed the topic of #launchpad-reviews to: On call: - || Reviewing: None || queue = [henninge, jtv, StevenK] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
StevenKqueue.append(StevenK)06:15
StevenKjtv: It can't be a tuple, they're immutable :-)06:16
jtvStevenK: won't queue = queue[1:] still work?06:21
StevenKI think that creates a new instance, doesn't it?06:21
jtvYes, so what?06:27
jtvWe care about the value of queue.06:27
StevenKYay, semantics :-)06:29
* StevenK notes lifeless is apparently OCR today06:29
StevenK*cough*06:29
jtvWhy, dear God, does my neighbor have to be such an enthusiast on the saxophone?06:33
StevenKjtv: Ah, but is he any good?06:34
jtvFrom the Halls of Montezuma to the Shores of Tripoli… he's a nice guy but he does make me wish he'd make the trip.06:34
jtvIt's *just* *not* *a* *saxophone* *melody*06:34
jtvBetter than some of the other stuff he's been playing today, I'll grant you, but still.06:35
jtvI'm no expert but there must be better choices of brass for this.06:39
lifelessStevenK: uhh, indeed. OTOH today is insane for me, sorry.06:57
lifelessthats why my name isn't in there.06:57
StevenKlifeless: Mostly teasing, so it's all good06:57
lifelessand it would have been morning only anyway, which finished 6 hours ago06:57
=== jtv changed the topic of #launchpad-reviews to: On call: - || Reviewing: None || queue = [henninge, jtv, StevenK, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
jtvhenninge: unexpected breakthrough with my branch; it turned out to be easy after all.  Shall I review yours now?09:15
henningejtv: please do ;)09:15
henningeThat's great news! ;)09:15
=== jtv changed the topic of #launchpad-reviews to: On call: - || Reviewing: None || queue = [jtv, StevenK, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
jtvhenninge: we're talking about your -3 branch, right?  I see that -1 is merged and -2 is approved.09:19
henningejtv: right. -2 is merged, too.09:19
* henninge checks that09:19
jtvOK.09:19
jtvThe UI doesn't say it's merged yet.09:20
henningeno, it's not :(09:20
henningeI'll do that now.09:20
jtv(Also, when I ran a Recife branch this morning, I noticed that the statistics said "changed in Ubuntu" on both sides.09:21
jtv)09:21
jtvBTW we're supposed to open a card per branch when we split things up like this.09:21
henningeright09:21
henningejtv: of cource, now the diff on the MP is wrong, it contains -2, too.09:22
jtvMaybe we can still set -2 as a prereq on the -3 MP.09:22
jtvhenninge: yup, we can.  Shall I just do that then?09:23
henningejtv: please do09:23
jtvok09:23
jtvDone.09:24
henningeAlthough I'll land it now anyway, dunno how that affects things09:24
jtv(Through resubmission, so don't be alarmed by any weird emails you may get about it)09:24
jtvWon't matter.09:24
henningeRecife has been update.09:26
henninged09:26
* jtv pulls09:27
jtvhenninge: in _makeTranslation, consider naming "is_other" to be consistent with what we do in the factory.09:33
jtvhenninge: oh never mind, I see it has a different meaning.09:35
henningeyes, it makes a "just other" message, not a sharing one.09:35
jtvIn a somewhat weird way—why not create a suggestion, then activate it on the appropriate side?09:37
henningejtv: activate + review.09:39
henningealthough, I guess that would work, too.09:40
henninge"markReviewed" and "setFlag"09:41
jtvhenninge: well you're doing the latter anyway.  But I'm talking about setting just the right flag, instead of setting one, then checking if it's the wrong one, and if so clearing it and setting the other one.  That's what I think you do now.09:41
henningeit does09:41
henningeI do09:41
henningejtv: I can change that.09:42
henningejtv: how's that: http://paste.ubuntu.com/536216/09:45
henningejtv: maybe this reads better ;) http://paste.ubuntu.com/536217/09:47
jtvhenninge: slow down, I was just looking at the last one.  :)09:47
henningetests still pass with it ...09:47
henningejtv: the second is the same but not a diff, just plain python09:48
jtvAh.  It's fine with me, though an "elif" could probably have been easier.09:48
jtv(though with a bit of repetition)09:48
jtvNever mind.  It's fine as you have it.09:48
jtvhenninge: next, now that you've betrayed knowledge of what the method does by renaming it, could you provide a docstring for _assertConfirmEmptyPluralOther?  I found the test hard to deal with because it assumes familiarity with a pretty large, complicated, underdocumented view class.09:50
henningeSure, I can do that.09:51
jtvThanks.09:52
jtvhenninge: in test_other_translation, I take it the "other translation" is actually a "current translation on the other side"?10:00
henningejtv: yes10:04
jtvMay be worth saying, to avoid confusion with "another translation"10:05
henningebut "current_translation_on_other_side" is such a long name for a variable.10:05
henningejtv: I think that if we consistently use "other side" and "other" in our new code, there shouldn't be any confustion.10:05
henninge(eat that "t" if you like)10:06
jtv:)10:06
jtvFair enough, but it'd be nice to have just one word in there somewhere to indicate that it's other-side, not just other.10:07
henningeI mean "other side" is a concept, just like "imported" was. We did not explain that every time we used it, either.10:07
jtvNo need to explain it every time, I agree.10:07
henningeI can add that.10:07
jtvThanks.10:07
jtv(Meanwhile we seem to be in conflict with db-stable again… I'll see if I can fix that)10:07
henningejtv: weren't you supposed to be at a dinner soon?10:08
jtvYes.10:08
jtvSo quickly:10:08
jtvSeveral notes on _set_dismiss_flags.10:08
jtvThe docstring says the flags are always set to False.  Begpardon?10:08
jtv(Not your fault I guess, but still: begpardon? :)10:08
henningegot your point ;)10:09
henninge"The flags have been initialized to False in the constructor. This method activates the right ones."10:10
henningejtv: ^ better?10:10
jtvBetter!10:10
jtvAlso, instead of the nested ifs, maybe just something like this:10:11
jtv    has_new_other = other is not None and (10:11
jtv        self.context.date_reviewed is None or10:11
jtv        self.context.date_reviewed < other.date_created)10:11
jtvIf you think that's easier, that is.  If you prefer the ifs, never mind.10:11
henningeusually I don't prefer complicated if constructs.10:12
henningejtv: much better, thank you.10:14
jtvA hybrid would work as well—keep the outer "if" but remove the inner one.10:14
jtvOh, nm then, glad you like it.  :)10:14
* henninge had to read and compare first. ;)10:14
jtv:-)  Another one that could be just slightly nicer to read is:10:14
jtvif len(local_suggestions) == 0 and not has_new_other:10:14
jtvinstead of if not(len(local_suggestions) > 0 or has_new_other):10:14
jtvAgain matter of taste though.10:15
henningegood idea, just now I stumbled when reading that line. ;)10:16
jtv:)10:16
jtvFinally, I'd leave out the "OK, let's set some flags" comment—since that's what the method does anyway.  If we need a comment like that, it's probably a sign that the method gets too long and/or complicated.10:16
henninge... I had considered removing that, too.10:17
henningejtv: actually, just figured out another improvement.10:18
jtv?10:18
henningehas_new_other is not needed, I can assign directly to can_dismiss_other10:19
henningeand just check for len(locals) == 010:19
jtvOh, yes.10:20
=== allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: None || queue = [jtv, StevenK, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
jtvThat way you don't have to keep track of whether your "early escape" condition still applies to the rest of the code in the method.10:20
henningejtv: in all its glory: http://paste.ubuntu.com/536231/10:20
jtvglory even?10:21
henningewell, "juice" ?10:21
henninges/new/newer/10:21
jtvThat really is a much nicer read.10:21
* jtv moves to push the button10:22
* henninge gets excited10:22
jtvdone!10:23
jtvthanks for the branch10:23
henningeYipee! (sp?)10:23
henningejtv: thanks for the review10:23
jtvI don't think spelling of that word is particularly rigorous.  I also just pushed an updated recife with the latest db-stable merged; it had some conflicts outside of translations.10:23
henningejtv: thank you very much. Enjoy your dinner!10:24
jtvThanks, bis morgen!10:24
henningeallenap: Nice to see you!10:24
henningea reviewer that is not having a holiday today ... ;)10:24
henningeallenap: if you start on jtv's branch, you can ask me about it. I hope I can answer ... ;)10:25
=== matsubara-afk is now known as matsubara
allenaphenninge: Hi there :)11:25
henningeHi allenap ;)11:26
=== allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: jtv || queue = [StevenK, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
allenapI'm not very quick off the mark today.11:53
=== allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: - || queue = [jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
StevenKallenap: Thank you for the review :-)12:28
=== mrevell is now known as mrevell-lunch
allenapStevenK: Welcome :)13:29
=== mrevell-lunch is now known as mrevell
=== allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: jtv || queue: [] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
bigjoolshey allenap!  I got an easy one for you: https://code.launchpad.net/~julian-edwards/launchpad/log-parser-bug-680463/+merge/4186514:30
henningeabentley: Hi!14:32
abentleyhenninge: Hi!14:32
henningeabentley: Are you able to finish the review for danilo's migration script branch?14:33
henningehttps://code.launchpad.net/~danilo/launchpad/migrate-current-flags/+merge/4136414:33
abentleyhenninge: Okay.14:33
henningeabentley: I have looked into it and it looks good to me now. I can approve it, too, but did not want to ignore you here.14:33
abentleyTBH, I wasn't sure how you guys wanted to handle it.14:35
henningeabentley: danilo's branch is the right one14:36
henningeHe is unavailable now, so I am going to land this.14:36
henningeabentley: is that what you meant by "handle it" ?14:37
abentleyhenninge: No, I mean that when I reviewed, jtv was going to revise it, but I gave him some suggestions on IRC that didn't appear in the review, and I don't know whether they appeared in danilo's branch...14:38
henningeabentley: I would not expect so, no :(14:38
henningeabentley: AFAICT danilo just fixed the problem jtv had indentified.14:39
henningeabentley: that was this channel, right?14:40
abentleyhenninge: yes.14:40
henningeabentley: I am trying to find the irclogs to that conversation14:41
abentleyhenninge: I'm just looking at the changes jtv made14:42
henningeabentley: where are you looking?14:42
abentleyhenninge: http://bazaar.launchpad.net/~jtv/launchpad/migrate-current-flags/14:42
henningeabentley: that only contains cosmetic changes14:44
henningeover danilo's branch, I mean.14:45
abentleyhenninge: True.  And I will approve it, but I will note that the changes are missing.14:45
henningeabentley: thanks. ;) Do you remember the day and roughly time of day you suggested these changes to jtv?14:47
abentleyhenninge: LP says it was 2010-11-22 and it was probably 13:00 UTC or so.14:47
allenapbigjools: I'll look at that one now!14:49
=== allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: bigjools || queue: [] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
bigjoolsallenap: it's a little gross but I have no better ideas14:49
allenapbigjools: It's cool. Why do you need the & 0xffffffffL line? If it's a number from a 32-bit field then that seems superfluous?15:02
bigjoolsallenap: I think it's to cope with sign.  I shamelessly copied it from the gzip module source15:02
bigjoolswithout thinking much about it, admittedly15:03
allenapbigjools: Oh yes, weird. +115:04
bigjoolsallenap: what do you think?15:05
bigjoolsit'll blow up if we read >~4.2GiB anyway15:05
allenapbigjools: I think it can stay. I can't see that it makes a difference, but my bit manipulation is rusty so I might be missing something.15:09
bigjoolsallenap: mine also :)15:10
bigjoolsI figured there was probably a good reason for it to be in the original code15:10
=== salgado is now known as salgado-lunch
=== matsubara is now known as matsubara-lunch
=== allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: - || queue: [] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
=== matsubara-lunch is now known as matsubara
=== allenap changed the topic of #launchpad-reviews to: On call: - || Reviewing: - || queue: [] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews
=== salgado-lunch is now known as salgado
salgadoanybody interested in reviewing a slightly long diff which exposes blueprints on the API?19:48
mwhudsonsalgado: maybe, but i can't promise a response time better than "today"19:55
salgadomwhudson, that'd be great; I wasn't expecting anybody would be able to review it before my EOD anyway. :)19:57
=== salgado is now known as salgado-afk
mwhudsonsalgado-afk: sorry about that20:31
salgado-afkmwhudson, about what?20:46
mwhudsondisappearing on you20:46
salgado-afkmwhudson, oh, no worries.  did you get my reply?20:47
mwhudsonsalgado-afk: only20:48
mwhudson<salgado> mwhudson, that'd be great; I wasn't expecting anybody would be able to review it before my EOD anyway. :)20:48
mwhudsondid you request a review?20:48
salgado-afkmwhudson, oh, good point, I forgot to tell you where my branch is.  do you want me to ask a review from you?20:49
mwhudsoni think i found it20:49
mwhudsonhttps://code.launchpad.net/~salgado/launchpad/expose-blueprints/+merge/4189820:49
salgado-afkyeah, that's the one. :)20:50
mwhudsoncool20:50
* mwhudson claims 20:50
=== matsubara is now known as matsubara-afk
wallyworldthumper: sorted(builds, key=attrgetter('id')) won't work - the named tuple doesn't have an id attribute :-)23:12

Generated by irclog2html.py 2.7 by Marius Gedminas - find it at mg.pov.lt!