=== jtv changed the topic of #launchpad-reviews to: On call: - || Reviewing: None || queue = [henninge, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [06:11] Since this is the reviewers channel… if we're going to write the queue in the topic in python, how do I make it follow our coding standards? [06:15] Submit a patch === StevenK changed the topic of #launchpad-reviews to: On call: - || Reviewing: None || queue = [henninge, jtv, StevenK] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [06:15] queue.append(StevenK) [06:16] jtv: It can't be a tuple, they're immutable :-) [06:21] StevenK: won't queue = queue[1:] still work? [06:21] I think that creates a new instance, doesn't it? [06:27] Yes, so what? [06:27] We care about the value of queue. [06:29] Yay, semantics :-) [06:29] * StevenK notes lifeless is apparently OCR today [06:29] *cough* [06:33] Why, dear God, does my neighbor have to be such an enthusiast on the saxophone? [06:34] jtv: Ah, but is he any good? [06:34] From the Halls of Montezuma to the Shores of Tripoli… he's a nice guy but he does make me wish he'd make the trip. [06:34] It's *just* *not* *a* *saxophone* *melody* [06:35] Better than some of the other stuff he's been playing today, I'll grant you, but still. [06:39] I'm no expert but there must be better choices of brass for this. [06:57] StevenK: uhh, indeed. OTOH today is insane for me, sorry. [06:57] thats why my name isn't in there. [06:57] lifeless: Mostly teasing, so it's all good [06:57] and it would have been morning only anyway, which finished 6 hours ago === jtv changed the topic of #launchpad-reviews to: On call: - || Reviewing: None || queue = [henninge, jtv, StevenK, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [09:15] henninge: unexpected breakthrough with my branch; it turned out to be easy after all. Shall I review yours now? [09:15] jtv: please do ;) [09:15] That's great news! ;) === jtv changed the topic of #launchpad-reviews to: On call: - || Reviewing: None || queue = [jtv, StevenK, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [09:19] henninge: we're talking about your -3 branch, right? I see that -1 is merged and -2 is approved. [09:19] jtv: right. -2 is merged, too. [09:19] * henninge checks that [09:19] OK. [09:20] The UI doesn't say it's merged yet. [09:20] no, it's not :( [09:20] I'll do that now. [09:21] (Also, when I ran a Recife branch this morning, I noticed that the statistics said "changed in Ubuntu" on both sides. [09:21] ) [09:21] BTW we're supposed to open a card per branch when we split things up like this. [09:21] right [09:22] jtv: of cource, now the diff on the MP is wrong, it contains -2, too. [09:22] Maybe we can still set -2 as a prereq on the -3 MP. [09:23] henninge: yup, we can. Shall I just do that then? [09:23] jtv: please do [09:23] ok [09:24] Done. [09:24] Although I'll land it now anyway, dunno how that affects things [09:24] (Through resubmission, so don't be alarmed by any weird emails you may get about it) [09:24] Won't matter. [09:26] Recife has been update. [09:26] d [09:27] * jtv pulls [09:33] henninge: in _makeTranslation, consider naming "is_other" to be consistent with what we do in the factory. [09:35] henninge: oh never mind, I see it has a different meaning. [09:35] yes, it makes a "just other" message, not a sharing one. [09:37] In a somewhat weird way—why not create a suggestion, then activate it on the appropriate side? [09:39] jtv: activate + review. [09:40] although, I guess that would work, too. [09:41] "markReviewed" and "setFlag" [09:41] henninge: well you're doing the latter anyway. But I'm talking about setting just the right flag, instead of setting one, then checking if it's the wrong one, and if so clearing it and setting the other one. That's what I think you do now. [09:41] it does [09:41] I do [09:42] jtv: I can change that. [09:45] jtv: how's that: http://paste.ubuntu.com/536216/ [09:47] jtv: maybe this reads better ;) http://paste.ubuntu.com/536217/ [09:47] henninge: slow down, I was just looking at the last one. :) [09:47] tests still pass with it ... [09:48] jtv: the second is the same but not a diff, just plain python [09:48] Ah. It's fine with me, though an "elif" could probably have been easier. [09:48] (though with a bit of repetition) [09:48] Never mind. It's fine as you have it. [09:50] henninge: next, now that you've betrayed knowledge of what the method does by renaming it, could you provide a docstring for _assertConfirmEmptyPluralOther? I found the test hard to deal with because it assumes familiarity with a pretty large, complicated, underdocumented view class. [09:51] Sure, I can do that. [09:52] Thanks. [10:00] henninge: in test_other_translation, I take it the "other translation" is actually a "current translation on the other side"? [10:04] jtv: yes [10:05] May be worth saying, to avoid confusion with "another translation" [10:05] but "current_translation_on_other_side" is such a long name for a variable. [10:05] jtv: I think that if we consistently use "other side" and "other" in our new code, there shouldn't be any confustion. [10:06] (eat that "t" if you like) [10:06] :) [10:07] Fair enough, but it'd be nice to have just one word in there somewhere to indicate that it's other-side, not just other. [10:07] I mean "other side" is a concept, just like "imported" was. We did not explain that every time we used it, either. [10:07] No need to explain it every time, I agree. [10:07] I can add that. [10:07] Thanks. [10:07] (Meanwhile we seem to be in conflict with db-stable again… I'll see if I can fix that) [10:08] jtv: weren't you supposed to be at a dinner soon? [10:08] Yes. [10:08] So quickly: [10:08] Several notes on _set_dismiss_flags. [10:08] The docstring says the flags are always set to False. Begpardon? [10:08] (Not your fault I guess, but still: begpardon? :) [10:09] got your point ;) [10:10] "The flags have been initialized to False in the constructor. This method activates the right ones." [10:10] jtv: ^ better? [10:10] Better! [10:11] Also, instead of the nested ifs, maybe just something like this: [10:11] has_new_other = other is not None and ( [10:11] self.context.date_reviewed is None or [10:11] self.context.date_reviewed < other.date_created) [10:11] If you think that's easier, that is. If you prefer the ifs, never mind. [10:12] usually I don't prefer complicated if constructs. [10:14] jtv: much better, thank you. [10:14] A hybrid would work as well—keep the outer "if" but remove the inner one. [10:14] Oh, nm then, glad you like it. :) [10:14] * henninge had to read and compare first. ;) [10:14] :-) Another one that could be just slightly nicer to read is: [10:14] if len(local_suggestions) == 0 and not has_new_other: [10:14] instead of if not(len(local_suggestions) > 0 or has_new_other): [10:15] Again matter of taste though. [10:16] good idea, just now I stumbled when reading that line. ;) [10:16] :) [10:16] Finally, I'd leave out the "OK, let's set some flags" comment—since that's what the method does anyway. If we need a comment like that, it's probably a sign that the method gets too long and/or complicated. [10:17] ... I had considered removing that, too. [10:18] jtv: actually, just figured out another improvement. [10:18] ? [10:19] has_new_other is not needed, I can assign directly to can_dismiss_other [10:19] and just check for len(locals) == 0 [10:20] Oh, yes. === allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: None || queue = [jtv, StevenK, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [10:20] That way you don't have to keep track of whether your "early escape" condition still applies to the rest of the code in the method. [10:20] jtv: in all its glory: http://paste.ubuntu.com/536231/ [10:21] glory even? [10:21] well, "juice" ? [10:21] s/new/newer/ [10:21] That really is a much nicer read. [10:22] * jtv moves to push the button [10:22] * henninge gets excited [10:23] done! [10:23] thanks for the branch [10:23] Yipee! (sp?) [10:23] jtv: thanks for the review [10:23] I don't think spelling of that word is particularly rigorous. I also just pushed an updated recife with the latest db-stable merged; it had some conflicts outside of translations. [10:24] jtv: thank you very much. Enjoy your dinner! [10:24] Thanks, bis morgen! [10:24] allenap: Nice to see you! [10:24] a reviewer that is not having a holiday today ... ;) [10:25] allenap: if you start on jtv's branch, you can ask me about it. I hope I can answer ... ;) === matsubara-afk is now known as matsubara [11:25] henninge: Hi there :) [11:26] Hi allenap ;) === allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: jtv || queue = [StevenK, jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [11:53] I'm not very quick off the mark today. === allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: - || queue = [jtv] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [12:28] allenap: Thank you for the review :-) === mrevell is now known as mrevell-lunch [13:29] StevenK: Welcome :) === mrevell-lunch is now known as mrevell === allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: jtv || queue: [] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [14:30] hey allenap! I got an easy one for you: https://code.launchpad.net/~julian-edwards/launchpad/log-parser-bug-680463/+merge/41865 [14:32] abentley: Hi! [14:32] henninge: Hi! [14:33] abentley: Are you able to finish the review for danilo's migration script branch? [14:33] https://code.launchpad.net/~danilo/launchpad/migrate-current-flags/+merge/41364 [14:33] henninge: Okay. [14:33] abentley: I have looked into it and it looks good to me now. I can approve it, too, but did not want to ignore you here. [14:35] TBH, I wasn't sure how you guys wanted to handle it. [14:36] abentley: danilo's branch is the right one [14:36] He is unavailable now, so I am going to land this. [14:37] abentley: is that what you meant by "handle it" ? [14:38] henninge: No, I mean that when I reviewed, jtv was going to revise it, but I gave him some suggestions on IRC that didn't appear in the review, and I don't know whether they appeared in danilo's branch... [14:38] abentley: I would not expect so, no :( [14:39] abentley: AFAICT danilo just fixed the problem jtv had indentified. [14:40] abentley: that was this channel, right? [14:40] henninge: yes. [14:41] abentley: I am trying to find the irclogs to that conversation [14:42] henninge: I'm just looking at the changes jtv made [14:42] abentley: where are you looking? [14:42] henninge: http://bazaar.launchpad.net/~jtv/launchpad/migrate-current-flags/ [14:44] abentley: that only contains cosmetic changes [14:45] over danilo's branch, I mean. [14:45] henninge: True. And I will approve it, but I will note that the changes are missing. [14:47] abentley: thanks. ;) Do you remember the day and roughly time of day you suggested these changes to jtv? [14:47] henninge: LP says it was 2010-11-22 and it was probably 13:00 UTC or so. [14:49] bigjools: I'll look at that one now! === allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: bigjools || queue: [] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews [14:49] allenap: it's a little gross but I have no better ideas [15:02] bigjools: It's cool. Why do you need the & 0xffffffffL line? If it's a number from a 32-bit field then that seems superfluous? [15:02] allenap: I think it's to cope with sign. I shamelessly copied it from the gzip module source [15:03] without thinking much about it, admittedly [15:04] bigjools: Oh yes, weird. +1 [15:05] allenap: what do you think? [15:05] it'll blow up if we read >~4.2GiB anyway [15:09] bigjools: I think it can stay. I can't see that it makes a difference, but my bit manipulation is rusty so I might be missing something. [15:10] allenap: mine also :) [15:10] I figured there was probably a good reason for it to be in the original code === salgado is now known as salgado-lunch === matsubara is now known as matsubara-lunch === allenap changed the topic of #launchpad-reviews to: On call: allenap || Reviewing: - || queue: [] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews === matsubara-lunch is now known as matsubara === allenap changed the topic of #launchpad-reviews to: On call: - || Reviewing: - || queue: [] || This channel is logged: http://irclogs.ubuntu.com/ || https://code.launchpad.net/launchpad/+activereviews === salgado-lunch is now known as salgado [19:48] anybody interested in reviewing a slightly long diff which exposes blueprints on the API? [19:55] salgado: maybe, but i can't promise a response time better than "today" [19:57] mwhudson, that'd be great; I wasn't expecting anybody would be able to review it before my EOD anyway. :) === salgado is now known as salgado-afk [20:31] salgado-afk: sorry about that [20:46] mwhudson, about what? [20:46] disappearing on you [20:47] mwhudson, oh, no worries. did you get my reply? [20:48] salgado-afk: only [20:48] <salgado> mwhudson, that'd be great; I wasn't expecting anybody would be able to review it before my EOD anyway. :) [20:48] did you request a review? [20:49] mwhudson, oh, good point, I forgot to tell you where my branch is. do you want me to ask a review from you? [20:49] i think i found it [20:49] https://code.launchpad.net/~salgado/launchpad/expose-blueprints/+merge/41898 [20:50] yeah, that's the one. :) [20:50] cool [20:50] * mwhudson claims === matsubara is now known as matsubara-afk [23:12] thumper: sorted(builds, key=attrgetter('id')) won't work - the named tuple doesn't have an id attribute :-)