[01:03] aujuju: Unable to fully remove Juju [01:04] m_3: still on for lunch today ? [01:04] m_3: that is more of a statement than a question, just confirming [01:10] davecheney: yup [01:12] m_3: just sent you an email, do you like Thai hawker food ? Luksa and the like ? [01:16] sounds good... I'm easy [01:17] m_3: groovy === meetingology` is now known as meetingology [07:21] mornings :) [07:29] fwereade_: howdy [07:29] davecheney, heyhey [07:30] things are looking up, we can bootstrap into other regions [07:30] * fwereade_ cheers [07:30] and I'm just about to get the local ec2 test running [07:30] davecheney, sweet [07:30] gustavo was supportive of moving the Provisioner into another package [07:30] davecheney, I spent most of the night hitting everything related to testing and zookeeper with an axe [07:30] so i can import it into the local tests [07:30] davecheney, yeah, I saw [07:30] davecheney, hope he is of this change too [07:31] fwereade_: looking for that race, or just because it deserved it [07:31] davecheney, duplicated bits and pieces everywhere, subtly inconsistent bits and pieces [07:31] davecheney, also a single monster test suite for almost everything in state [07:32] davecheney, the collective pain passed my threshold [07:32] davecheney, and it's the sort of thing I really *don't* want to do piecemeal [07:32] fwereade_: excellent work [07:33] davecheney, any ad-hoc duplications I leave lying around will, according to the law of sod, be those that someone sees and copies next time they need to take to ZK, or use a State, or whatever ;) [07:39] fwereade_: did you move zkSuite into juju-core/testing ? [07:39] or are you planning too ? [07:40] the zkSuite i refer to comes from cmd/jujud [07:40] davecheney, I'm planning to drop it and use juju-core/testing.ZkConnSuite for initzk, and juju-core/state/testing/StateSuite for the others [07:41] davecheney, just unpicking that bit right now actually :) [07:41] davecheney, neither of those exist yet, except this this tree ofc [07:41] fwereade_: excellent, I hope it gets commited soon [07:42] 'cos I need that to start a zk to back the provisioner for the local ec2 tests [07:42] davecheney, me too... [07:42] davecheney, ah, cool [07:43] davecheney, I'm not sure it will actually get proposed until you've gone to bed [07:43] davecheney, that said I hope it will before eod for me [07:44] davecheney, so if you do happen to see it over the weekend, and are able to give the bits that hit your code a once-over (and hopeful LGTM), I think it would help [07:44] davecheney, it's gong to be much too big for a single person to review it effectively, even though *most* of the changes are from splitting up state_test [07:47] understood [07:47] review backlog ... sigh === mthaddon` is now known as mthaddon [08:11] davecheney, cmd/jujud/main_test.go [08:11] davecheney, is it intentionally not in the main package? [08:11] davecheney, I thought you changed all those to be internal? [08:12] let me check, that may have been an accident [08:12] davecheney, it looks as though that test isn't actually run any more [08:13] sorry, that was an accident [08:13] hmm, looking further [08:13] i didn't touch main_test [08:14] but it should be fixed [08:15] davecheney, cool, I'll pick thoe up with the one I'm doing [08:16] ok, thanks [08:17] I can do it too, but it'll be depending on my other services branc [08:18] davecheney, since I'm already hitting everything to do with testing I think it fits best with what I'm doing [08:19] kk [08:19] davecheney, actually, do you have a few minutes to take a preliminary look at what I've done? assuming I haven't broken anything in the latest pass, I'll propose -wip in a couple of mins [08:20] davecheney, or will I be keeping you at work inappropriately? ;) [08:21] fwereade_: yeah fire it off [08:22] davecheney, https://codereview.appspot.com/6348053 [08:23] davecheney, testing/zk.go, and state/testing/testing.go, are at the heart of it all [08:24] davecheney, most of the stuff in the state package can otherwise be pretty much ignored for now, it's just test-moving [08:24] davecheney, so if you take a look at those, and how they affect the jujud tests, that would probably be most directly useful [08:25] * davecheney looks [08:34] * fwereade_ passes davecheney the goggles, and hopes they do something [08:35] fwereade_: looks pretty good to me [08:35] davecheney, cool, thanks for taking a look :) [08:36] you could probably split this into two changes, to reduce the sticker shock [08:36] but 90% of the change is one liners in a file [08:38] davecheney, yeah, maybe I should do the state_test split separately [08:38] davecheney, bah :) [08:38] i don't think it's worth it, this branch will probably take a few review cycles, so it's probably not saving much [08:39] davecheney, yeah, I must admit I'm not especially enthused by the idea, but the I wouldn't be ;) [08:40] davecheney, hmm, an idea [08:40] davecheney, state_test.ConnSuite should probably not be used anywhere near as much as it is [08:41] davecheney, if I move the tests that use zkConn directly out into their own zk-substrate-specific test it would probably be a good thing [08:41] davecheney, but that's surely one for a new CL [08:44] fwereade_: stepping offline for a while, gonna see what is happening in the real world [08:44] davecheney, take care, have fun [08:44] fwereade_: you too [09:31] TheMue, heyhey [09:31] fwereade_: Hi [09:39] fwereade_: Oh, update tells me to reboot. One moment. [09:43] fwereade_: So, back again, just submitted the deleted-is-now-removed-change [09:43] TheMue, cool [09:43] TheMue, I'll merge that in a mo [09:44] TheMue, I have a hideous monster of a branch in progress [09:44] TheMue, but it does remove a whole bunch of duplication across the tests that hit state and/or zookeeper so hopefully it won't be too controversial [09:44] TheMue, do you have anything else likely to land soon? [09:44] fwereade_: I'm still porting the firewall, it uses multiple watchers. And now I've got a method with a callback inside a callback. :( [09:45] fwereade_: No, I'll need some time. [09:45] TheMue, cool [09:45] TheMue, an internal updates channel may be helpful if I've understood what you're doing correctly [09:46] TheMue, ie the main loop selects on w.subwatcher.Changes and w.updates [09:47] TheMue, and a separate goroutine for each additional watcher sends on w.updates for the attention of the main loop [09:48] TheMue, sensible/relevant? [09:48] fwereade_: Maybe an approach, yes. I'll take a look how it matches. But it SGTM. [09:49] TheMue, if by callback-inside-callback you just mean consuming the initial event from a new watcher before sending it off on its own goroutine I think that's sensible and necessary [09:56] fwereade_: I've got to get deeper in the code first, understanding what happens there today. [09:57] TheMue, SGTM, give me a shout if you see anything particularly surprising, I seem to have spent a disturbing amount of time thinking about this sort of problem recently [11:53] hey. [11:54] Aram, heyhey [12:29] fwereade_: Could you please help me getting yield right? [12:29] Aram: Hi btw [12:29] TheMue, I'll do what I can :) [12:30] TheMue, what's the problem? [12:30] fwereade_: I understand it as a generator returning the yielded value with each call. So far no problem. [12:30] TheMue, but @inlineCallbacks is weird? [12:31] fwereade_: But when the call to the generator function has a list as argument and inside the func this list is iterated and every time a yield, what do I get? [12:32] fwereade_: And those inlineCallbacks too, yes. ;) [12:32] TheMue, not sure I follow the first bit, can you point me to the code? [12:33] TheMue, the idea of inlineCallbacks is that you repeatedly yield a Deferred, and the result of that Deferred is sent back into the generator once it's fired [12:33] TheMue, basically it lets you write callback-based code and kid yourself it's not really using callbacks [12:34] TheMue, so the critical thing is not to think of inlineCallbacks-decorated methods as being generators at all [12:35] TheMue, it's a creative and useful abuse of generators but that's not really a useful perspective from which to view them IMO [12:37] fwereade_: OK, thx, a first hint. And forget my first sentence, I interpreted the indent inside firewall.py wrong. [13:07] So, organized my checkup at the dentist on Monday morning. *dislike* [13:25] TheMue, Aram: I have the most horrifying CL known to man, just proposed at https://codereview.appspot.com/6348053 [13:25] oh man [13:25] TheMue, Aram: it's explained in great detail on codereview [13:26] Aram, I hope that it moves us a significant step towards substrate-independent state testing, which is why I'm pointing it out to you in particular [13:27] TheMue, because it hits a lot of tests that you yourself wrote, I would particularly appreciate your feedback [13:28] fwereade_: I'm already looking. [13:29] fwereade_: Btw, I often read CL here, but I've been not able to find the long version of this abbrev. Could you help me? [13:30] TheMue, ChangeList, apparently :) [13:30] fwereade_: Thought so, indeed. But it seemed too simple. ;) [13:31] fwereade_: I'm knowing it as a change set. [13:32] fwereade_: http://en.wikipedia.org/wiki/Changeset [13:33] TheMue, indeed [13:33] TheMue, seemed easiest to just adopt the preferred local terminology :) [13:33] fwereade_: Yes, only wanted to know. Maybe there's a history behind it. [13:51] TheMue, Aram: btw, if I do appear to be making unsupportable statements in the description, or to otherwise be on crack, please point it out... I'm somewhat nervous that niemeyer is going to reject it on principle, and I'd like it to be as sane as possible in all respects other than size ;) [13:52] fwereade_: Normally your ideas have very good reasons. [13:53] TheMue, thank you -- but occasionally total nonsense slips out past the internal censor, and N other opinions are very helpful ;) [13:53] fwereade_: *lol* [14:19] ..ooOO( Note to Mr. Reade: This change is indeed a *monster*. ) [14:58] fwereade_: You've got a review. [15:31] TheMue, tyvm for review [15:31] TheMue, how about "conf" instead of "any"? [15:36] fwereade_: I'm missing the intention of that type. The name should reflect this. [15:37] TheMue, it's for holding environ configurations, haven't noticed any other uses [15:40] fwereade_: We could reuse it naming it like "dictionary", otherwise especially for this case "environConfig". [15:41] TheMue, SGTM [15:41] fwereade_: But that are all minors. In general it seems to be an important change to me. [15:42] TheMue, fantastic [15:42] fwereade_: And cleaning up the test tables (all in the methods or all out of them, simplification, anonymous structs) can be done later. [15:43] TheMue, yeah, I'm not sure I feel those are important enough to do until I have reason to modify them [15:43] TheMue, the big reason for this change is that I'm about to extend state.Initialize and without consistency that will be a nightmare [15:44] TheMue, the little reason is just low-level ongoing frustration as I complained about ;) [15:45] fwereade_: :D [22:08] aujuju: juju: ERROR Unexpected Error interacting with provider: 409 CONFLICT