[04:43] Bah! [04:44] QT CREATOR!!!!!!!!! [07:14] alf_: do you have any thoughts regarding a new separate namespace for main loop, timer service.. [07:19] I don't think it's a terrible idea, but I'm not sure what it would be. [07:19] scheduler is a hot candidate.. like event_loop [07:20] That's a pretty decent name. [07:20] anpok: mir::services? scheduler is not bad [07:20] RAOF: btw, regarding mesa - all issues so far were solved through pulling in further autotools related patches from master [07:21] You autotools! [07:21] RAOF: what is currently in the archive is a non-functional gallium backend [07:21] Ah. [07:21] Heh. [07:21] RAOF: now it stumbles getting a good EGLConfig - i.e. surface attribute bit is wrong iirc [07:22] alf_: sounds good but, but what is not a service? (maybe I misnamed timer service?) [07:22] -but [07:23] anpok: fair point [07:26] RAOF: ah right, this one is really odd.. all config entities it checks have EGL_PBUFFER_BIT = 0x1 and one that is not listed in egl.h 0x10... so it is 0x11 while we want EGL_WINDOW_BIT = 0x4 to be set [07:26] Hm. Incorrect shift? [07:27] I have not yet found the place where those config objects get assembled.. [07:28] oh no it isi 0x8 + 0x1 actually [07:28] but that one is also not listed in egl.h [07:28] not as a surface type at least === robjh- is now known as peps [07:30] alf_: i would like to introduce an interface like main loop that does not say "i am a single instance" - maybe something like EventLoop or Scheduler .. dunno .. which provides the FD/Timer/ActionQeueu (services :)).. [07:34] anpok: Whether this is going to be useful depends on what needs our consumers have. For example at the moment we have a need for synchronized FD + Signal + ActionQueue (current MainLoop) and a Timer which doesn't need to be sync with them. [07:35] s/synchronized/serialized/ [07:35] hm input sender needs fd + timer, none of them need to be serialized.. or in the main loop or .. [07:36] anpok: I guess if two services don't need to be serialized between them, we might as well pass them as separate interfaces? [07:36] yes [07:37] oh .. sorry that was what I wanted to express [07:37] s/an interface/a class/ [07:38] The way AsioMainLoop provided both mir::MainLoop and mir::Timer? :) [07:38] yes.. [07:39] so that we can decide within server configuration which thread handles which type of events for which part of the mir functionality [07:39] anpok: RAOF: Didn't we split them apart to make things simpler? :) [07:39] yeah lets revert [07:41] anpok: hmm, if we really need this can we somehow use composition to provide the functionality and keep the eveng logic in separate classes? [07:42] anpok: instead of going back to the the loop super file? [07:42] yes.. that should be a driving goal [07:42] also getting rid of the unpredictable parts of asio [07:43] I wont be working on that this week or so.. [07:43] Just thought about it again, as I am updateing the MPs again [08:05] Man I wish gdb worked. [08:23] RAOF: ? It has been working for me for at least a decade [09:03] alan_g: Tried it on mir_unit_tests recently? It segfaults while trying to load the debugging symbols. [09:04] RAOF: yes, I've been using it to track down weird behaviour in trust-session APIs === chihchun_afk is now known as chihchun === chihchun is now known as chihchun_afk === dandrader is now known as dandrader|afk === dandrader|afk is now known as dandrader === chihchun_afk is now known as chihchun [11:10] alf_: thanks for the clue - that's fixed now and I don't have to worry about a mystery CI failure. [@https://code.launchpad.net/~alan-griffiths/mir/rework-test_client_library_old.cpp/+merge/222018/comments/533359] [11:11] alan_g: great, glad I could help === chihchun is now known as chihchun_afk === chihchun_afk is now known as chihchun === pete-woods is now known as pete-woods-lunch [11:58] alan_g: i just realized that you suggested scheduling, while I propose scheduler instead.. [11:58] anpok: scheduler is likely better. [11:59] ... ok then I will rebase the input sender on that.. === alan_g is now known as alan_g|lunch [12:07] hm I should move TimerService too === chihchun is now known as chihchun_afk === dandrader is now known as dandrader|afk === alan_g|lunch is now known as alan_g === pete-woods-lunch is now known as pete-woods [12:59] alf_: I am inclined to rename mir::graphics::EventHandlerRegistrar to scheduler::FDHandlerRegistrar [13:00] because in input::InputSender I only use that part of the main loop interface === dandrader|afk is now known as dandrader === chihchun_afk is now known as chihchun [14:00] alan_g: alf_: kdub_: is the order in which parts of the DisplayServer are started and stopped relevant? [14:00] I see we do have test cases that ensure a specific order.. [14:01] anpok: yes (but I can't remember details) [14:01] anpok: yes [14:01] I think about your complaint about the name TimerService.. [14:03] anpok: TimerServiceManagerer :P [14:03] hehe [14:04] that part of the interface is only there to start&stop it.. so maybe we could inverse it.. and make it an observer of the server state, and react by starting and stopping the thread [14:04] or provide a StartStoppable (suggestions welcome) interface [14:05] that could be driven by DisplayServer [14:05] but that means the we strictly follow insertion order on start and backwards on stop.. [14:05] s/the we/that we have to/ [14:07] or on third thought..: [14:07] anpok: there is also the pause/resume case which has some special needs [14:07] class AlarmLoop : public AlarmService === alan_g is now known as alan_g|tea [14:38] kdub_: for your alpha question yesterday... === alan_g|tea is now known as alan_g [14:38] kdub_: the issue with the alpha originally was yes, the alpha channel in nested was not initialized [14:39] kdub_: so then we initialized it to opaque === jono is now known as Guest92020 [14:39] kdub_: that doesn't work for the split greeter work as it relies on being able to show through multiple nested sessions [14:40] kdub_: so then I modified it so that a nested transparent display buffer would get its alpha channel written [14:41] kdub_: and the last change was to make it actually write correct alpha [14:41] kdub_: to avoid alpha^2'ish effects === chihchun is now known as chihchun_afk === dandrader is now known as dandrader|lunch === chihchun_afk is now known as chihchun === chihchun is now known as chihchun_afk === chihchun_afk is now known as chihchun === chihchun is now known as chihchun_afk === chihchun_afk is now known as chihchun === dandrader|lunch is now known as dandrader === chihchun is now known as chihchun_afk === chihchun_afk is now known as chihchun === alan_g is now known as alan_g|EOD === dandrader is now known as dandrader|afk === chihchun is now known as chihchun_afk === chihchun_afk is now known as chihchun [18:52] sigh, why did we lose the rich pixel format type [19:08] kdub_: from the conversations I heard it was just side effect of unification of two types.. === dandrader|afk is now known as dandrader [19:13] heh, i'd say the type was just c-ified :) [19:24] code is patient [19:24] or version control systems at least [19:25] kdub_: maybe a good time to get that mp through :) [19:27] yeah, seems like a big chunk to improve given how pervasive the type is though [19:28] other fish to fry [19:30] hm are there affordable displays to test depp color pixel formats [19:31] i only know that mine sucks even at displaying 8 bit per channel === chihchun is now known as chihchun_afk === chihchun_afk is now known as chihchun [20:34] hi racarr_ === DalekSec_ is now known as DalekSec [20:57] anpok: hi. What's up? [20:58] seems like there was netsplit or something. [20:58] did I miss something?!?! [20:59] nope [21:00] haha [21:00] I was just converting cursor test stuff to inprocess server test [21:00] to find this intermittent failure [21:00] and found that but still have the other half of the tests to convert now. [21:00] then...I have to do the same thing for this enable usb touchscreen branch lol [21:01] I feel good about getting more fake devices in fake event hub though [21:01] I was thinking after that branch lands I will add a fake joystick. [21:03] fake wacom style tablet, etc. [22:11] hmm [22:11] I have a weird throw in std::mutex::lock I dont understand [22:12] Throws std::system_error when errors occur, including errors from the underlying operating system that would prevent lock from meeting its specifications. The mutex is not locked in the case of any exception being thrown [22:12] like what! [22:13] oh I understand [22:13] lol [22:13] good talk [23:26] why do we have a Width /and/ a DeltaX [23:32] anpok: The Dell UltraSharp line does (reasonably) affordable 10bpp panels; even the crappier ones are full 8bit. :)