tsdgeosanyone has an idea of why indicator-keyboard would not work at all under unity7?09:21
tsdgeoscimi: you there?09:29
Saviqtsdgeos, gsettings list-recursively com.canonical.indicator.keyboard ?09:52
tsdgeosSaviq: fixed it09:52
tsdgeosthe keyboard plugin for the settings daemon was disabled for some unknown reason09:52
cimitsdgeos, yeah09:55
tsdgeoscimi: thanks, i figured it out myself already09:55
tsdgeosltinkl: ping10:32
mzanettiMirv, when you have some moments, please kick a rebuild of the inputinfo silo10:43
ltinkltsdgeos, pong10:58
tsdgeosltinkl: see the MR comment10:58
ltinkltsdgeos, ah right, the test needs moving probably, will fix10:59
pstolowskicimi, hey, how is the situation with single-preview looking?11:06
cimipstolowski, running tests11:06
tsdgeosltinkl: make xvfbtestShell FUNCTION="Shell::test_inputEventsOnEdgesEndUpInAppSurface" also fails in your branch but since it passes in silo64 branch i guess we can "ignore" it11:07
Mirvmzanetti: hmm, it's already in QA queue since you said it's ok to go?11:07
Mirvmzanetti: should I ask QA to remove it?11:07
ltinkltsdgeos, I guess mzanetti fixed it in another branch in that silo11:07
cimipstolowski, I think tests are passing11:08
cimitsdgeos, can you have a look at my single preview branch?11:09
pstolowskilunch time..11:09
tsdgeoscimi: sure11:10
tsdgeoscimi: you still need to fix the "needs fixing" i did yesterday11:11
cimitsdgeos, I did merge in activation progress11:12
cimiit says nothing to be merged11:13
* cimi checks again11:13
tsdgeoscimi: the other needs fixing11:13
cimitsdgeos, is the MP fine now? Updated the commit and description message12:01
tsdgeoscimi: need to review it now :D12:02
tsdgeoscimi: in which silo do you guys have this stuff?12:10
cimitsdgeos, 7612:10
cimitsdgeos, let me rebuild12:10
tsdgeoscimi: there?12:29
cimitsdgeos, yes12:34
tsdgeoscimi: any reason we need the previewLoader in PreviewView.qml ?12:34
tsdgeoswould just having the Previews.Preview in there be as good/better?12:35
cimitsdgeos, maybe, or we can play with the "active" property and do some checks on the model12:36
cimitsdgeos, I initially thought the model might be missing something so as a transition from the PreviewListView I used a loader, but i then removed the active property I was using so12:37
tsdgeoscimi: i'd prefer if you remove the loader13:45
tsdgeosshould remove some complexity from the code13:45
mterrySaviq, remember how we asked for feedback from Alex (from design) about the warn-on-launching-xapp dialog?  Did we ever get that?14:12
Saviqmterry, not in my inbox14:12
mterrySaviq, I'll poke paty14:12
ltinkltsdgeos, kbdIndicator test fixed14:12
mterrySaviq, sent another email, this time with Paty on cc too...  :-/14:17
tsdgeosltinkl: but then we're not testing the shortcuts with this new test, no?14:18
ltinkltsdgeos, hmm, right, I'll have to add a new test for that, the logic changed a bit14:19
tsdgeosltinkl: could you add it?14:19
ltinkltsdgeos, sure14:19
dandraderdoes anybody know how can I stop that spam in unity8.log? "loadExtendedAttributes: menu item does not contain 'x-canonical-scroll-action'"14:20
Saviqdednick, ↑14:27
dednickdandrader: Saviq: https://code.launchpad.net/~nick-dedekind/qmenumodel/logging-categories14:28
dandraderdednick, thanks14:28
mterryltinkl, so libtimezonemap pulls in gtk?  That's another reason to use geonames14:30
dednickalthough i dont really like the fact that i'm logging it as debug...14:30
dednickmaybe should make it warning; and only log out critical...14:30
ltinklmterry, hmm it probably does with the widget... that we're not using14:31
mterryltinkl, I know system settings uses it too, but we should try to minimize use I guess14:31
* ltinkl nods14:32
ltinklmterry, do they plan to get rid of it?14:32
mterryltinkl, I believe system settings intends to port, yet14:32
ltinklmterry, ok, then we might want to coordinate with them, when it happens14:33
mterryltinkl, working on coordinating14:34
ltinklmterry, great, thanks!14:37
tsdgeosmzanetti: maybe you can do https://code.launchpad.net/~aacid/unity8/deprecatedNetworkingStatus/+merge/286350 ?14:58
mzanettitsdgeos, ack14:59
mzanettipstolowski, tsdgeos, cimi: your opinion about this? https://code.launchpad.net/~ken-vandine/unity8/share_data_uri_string/+merge/28667615:05
cimimzanetti, pstolowski tsdgeos it's an api choice, up to you15:06
cimiwe want to support multiple uri15:06
mzanettiyes, I would agree we want to support it...15:06
tsdgeosi thought it was settled you guys wanted to support both single string and array ?15:06
tsdgeosand that typeof was needed?15:07
mzanettiah ok... I missed that15:07
mzanettibut yes, that sounds good15:07
mterryltinkl, you're not in #ubuntu-touch?15:07
ltinklmterry, now I am :)15:07
=== JMulholland_ is now known as JMulholland
pstolowskicimi, mzanetti i'm not sure what the proposed change does tbh. or are you asking whether we should rename from 'uri' to 'uris'?15:13
mzanettipstolowski, yeah... that, or support both I guess15:13
mzanettiso either we rename it "uris" and use the typeOf() thing to see if its an array or a single one15:14
mzanettior we add uri and uris15:14
tsdgeosmzanetti: or just use uri and it can be a string or an array, smaller change, just needs a change in our side15:17
tsdgeoseven if the name is a bit confusing, noone will die :D15:17
pstolowskimzanetti, yeah, i second that15:17
pstolowskiwhat tsdgeos says15:17
mzanettikk then... wfm15:18
mzanettido we have some documenting text that this can be a list?15:19
mzanettiI really just checked the clock if it's 6pm ^ :D15:19
pstolowskimzanetti, yes we do15:30
mzanettikk then. problem solved. cimi, will you fix that uri thing then?15:31
cimimzanetti, sure this afternoon15:31
pstolowskimzanetti, http://bazaar.launchpad.net/~unity-team/unity-scopes-api/trunk/view/head:/src/scopes/PreviewWidget.cpp15:31
pstolowskimzanetti, that's how it was documented when content-sharing landed in unity815:32
pstolowskimzanetti, (see Content sharing section)15:32
mzanettipstolowski, ack. found it. lgtm15:32
mterryltinkl, oobe almost ready?  I thought we needed this whole "alternate city names" feature for searching timezones15:36
ltinklmterry, not critical... more like would be "nice to have"15:37
mterryltinkl, I guess since we match system settings there...15:37
cimitsdgeos, we have some code in PreviewListView (check old branch) around a previewData thing when preview close... is this code working?15:40
tsdgeoscimi: i can't tell for sure, why?15:40
cimitsdgeos, looks like I can remove that15:40
cimitsdgeos, if you can confirm15:40
tsdgeoswell, why do you want to remove it?15:41
cimitsdgeos, I guess is dead code15:41
tsdgeoscimi: why do you guess that?15:42
tsdgeosi mean what makes you think it's not needed?15:42
cimitsdgeos, what is previewData?15:42
cimitsdgeos, Preview.qml has no previewData property15:43
* cimi looks annotation15:44
cimitsdgeos, looks like it's there for test previewWidgetFactory and you wrote that?15:46
mterrySaviq, I'd like to throw relock-during-tutorial in there, will do so now if you don't object15:46
mterry(silo 64 that is)15:47
Saviqmterry, please do15:47
tsdgeoscimi: hmmm, previewWidgetFactory?15:47
cimitsdgeos, nope that was a grep previewData15:47
tsdgeosah, ok15:47
mterrySaviq, done15:47
Saviqhuh, I wonder, why doesn't mako rotate in windowed mode ¿?15:48
Saviqmzanetti, any idea ↑?15:48
cimitsdgeos, looks like ooooold code http://bazaar.launchpad.net/~unity-team/unity8/trunk/revision/494.1.115:48
cimitsdgeos, old API?15:48
Saviqaah maybe pre-silo 1015:49
tsdgeoscimi: ok, yeah remove the previewData code, can't find what it'd do15:52
cimitsdgeos, and that previewData.cancelAction() ?15:54
=== morphis_ is now known as morphis
cimitsdgeos, previewModel has similar actions?15:54
tsdgeoscimi: i'd say cancelActivation is basically it15:55
tsdgeosmaybe not15:55
tsdgeospstolowski: there?15:55
cimimaybe pawel remembers15:55
pstolowskitsdgeos, y15:55
cimipstolowski, we had previewData.cancelAction()15:55
tsdgeospstolowski: we have some code that says15:55
tsdgeos/ Cancel any pending preview requests or actions15:55
tsdgeosand then call cancelAction on something callled previewData15:55
tsdgeosi can't find any cancelAction on unity-api not unity-scopes-shell15:56
tsdgeosthis is when hiding the preview on the dash15:56
pstolowskitsdgeos, hmm, interesting. and previewData is what? a PreviewModelInterface object?15:57
tsdgeosit's a good question15:57
tsdgeosno, it was somthing that came from a model long time ago15:58
tsdgeoswas called previewData in the model too15:58
tsdgeospstolowski: i guess the better question is, do we have to call something else other than scope.cancelActivation(); when closing the preview ?16:00
pstolowskitsdgeos, still looking16:01
Saviqtsdgeos, re: orientation bug, easiest to repro on mako is with silo 10, force desktop mode in display indicator, launch camera app, rotate phone16:01
=== dandrader_ is now known as dandrader|lunch
pstolowskitsdgeos, i think cancelActivation will only have effect on activate requests and action activation and will do nothing for previews. however, when it comes to previews, when you drop preview model instance on the floor it cleans up its stuff, so i don't see any need for explicit calls16:09
pstolowskitsdgeos, so the question is if preview object is properly destroyed on qml side when not needed?16:09
tsdgeoswe will leave cancelActivation since it's there nowadays16:10
cimiand we had this code that does nothing :D16:10
pstolowskitsdgeos, preview objects have no cpp owener, so should be taken over by qml16:10
tsdgeospstolowski: it should be dropped, yes16:11
tsdgeoswill double check as soon as cimi does the last change16:12
cimitsdgeos, I can push now16:12
cimitsdgeos, needless to say that I run tests and now fail without the Loader :D give me 5 mins16:16
cimitsdgeos, then I push, really.16:16
tsdgeosok :)16:17
cimitsdgeos, ok16:30
cimitsdgeos, also, silo is rebuilding unity816:32
tsdgeoscimi: code looks good, will do a phone test tomorrow16:44
cimitsdgeos, sure thanks16:44
cimimzanetti, tsdgeos I'm wondering if this will do the content sharing thing http://paste.ubuntu.com/15181460/16:56
cimitesting the code is more complicated because it would be basically testing contenthub, and we dont want to16:57
tsdgeoscimi: well you can test that a single street goes to one place and that an array goes thorugh the other, no?16:58
cimitsdgeos, the logic is inside the content picker code, so we will have to test the picker in the qmltest somehow16:59
tsdgeoscimi: you mean that code is executed by the content picker and not us?17:00
cimitsdgeos, yeah17:02
tsdgeoshave to go now, cinema waiting, ping me tomorrow and we can think about it17:03
=== zequence_ is now known as zequence
=== dandrader|lunch is now known as dandrader
=== alan_g is now known as alan_g|EOD
=== dandrader is now known as dandrader|afk
lpottermzanetti: we are targetting qt 5.4 with that qinputinfo?19:24
mzanettilooks like, yes19:24
lpotterthat's what I thought, just making sure :)19:27
=== dandrader|afk is now known as dandrader
=== philipballew is now known as Guest44851
=== RAOF_ is now known as RAOF

Generated by irclog2html.py 2.7 by Marius Gedminas - find it at mg.pov.lt!