=== shardy is now known as shardy_lunch === shardy_lunch is now known as shardy [14:36] magicalChicken, are you around today ? [15:13] smoser: I am out of town, but I can do some work [15:14] I may just be slow to respond [15:14] do you want to ? i got somethign i want to have done today, but i can do it or let you do it :) [15:14] Sure [15:16] ok. give me 10 minutes. and i'll point you at it [15:17] smoser: ok [15:43] bah. almost there, [15:46] magicalChicken, you still there? [15:51] smoser: yeah [15:52] for bug https://bugs.launchpad.net/maas/+bug/1582323 . i regressed that when i "fixed" it. i want to put the old behavior back in [15:52] git commit is 63501f44 that regressed [15:54] smoser: so it was the fix for LP:1595302 that brought the regression in [15:54] yeah [15:54] so just rewvert the commit [15:54] but need to add some unit tests to make sure i dont stupidly break it again [15:54] :) [15:55] i just read code wrong [15:55] and didn't test [15:55] util.mergemanydict has a wierd function signature [15:55] it kindo f works backwards ... [15:55] smoser: sure, I'll get some unittess written [15:56] smoser: oh, yeah it makes more sense with reverse=True [16:01] magicalChicken, http://paste.ubuntu.com/23659465/ [16:01] that is what i had just been playing with [16:02] lots of times i find that decorators get long winded, so this was kind of a way to try to make them less, but still wrap the 3 functions inside that fetch_base_config that basically need tob e wrapped [16:12] magicalChicken, ^ you see that ? if you think you make reasonable tests without my fancy / overengineered wrap_and_call, then feel free :) [16:13] smoser: Yeah, just saw that [16:13] it looks pretty good to me, the decorator is pretty simple [16:13] see test_ntp_handler [16:13] that is what i wanted to kind of avoid [16:14] the large indentation that you get with something liek that [16:14] or the lots-of-decorators if you got that route instead. [16:14] yeah, the with chain gets hard to read [16:17] it may actually be nice to move the multi-wrap function into helpers, the 'cloudinit.stages.util' could be set with a kwarg to make it more generic [16:20] magicalChicken, yeah. [16:20] i was thinking that too === rcj` is now known as rcj === rcj is now known as Guest61336 [16:47] smoser: I moved the wrap_and_call function into helpers and copied the unittest you had written in [16:48] I've gotta head out for a little bit, but I can the rest of the unittests for fetch_base_config() written this afternoon === Guest61336 is now known as rcj [16:49] magicalChicken, great. [17:08] magicalChicken, note, i have *kwargs wrong [17:08] should be **kwargs [17:08] try: [17:08] return func(*args, *kwargs) [17:31] * powersj really needs to get the unit tests on merge requests going :( [19:15] hi, working on my aix-port. Quick question on /var/lib/cloud/data/ssl (specific case), but also on function and usage of /var/lib/cloud by deployed images [19:16] i am guessing - but it seems /var/lib/cloud is where the first data-source gets "copied" to, so that on subsequent reboots - the "networked" datasource is no accessed - everything is coming from /var/lib/cloud. [19:17] I would like a simple world :) [19:18] re: /var/lib/cloud/data/ssl - is cloud-init (going to copy) that data from there to where "it should be" aka dist default location(s)? [19:42] new question: keeping it to two sources: what is the difference between source NoCloud and ConfigDrive - both seem to be referencing (virtual) CD/DVD, but how are they different? [19:48] bbl, have to change wifi networks... [22:00] smoser: Are you going to have a chance this week to look at the integration test merge proposal? I believe all the changes you requested are complete. [22:53] smoser: I got that fixed in the version in helpers. I'm running a bit late, but I will get a pull request submitted for the unittests tonight