kkeithleyquestion about ppa dependencies:  one of my ppas (https://launchpad.net/~nfs-ganesha/+archive/ubuntu/nfs-ganesha-2.8) has a dependency on https://launchpad.net/~nfs-ganesha/+archive/ubuntu/libntirpc-1.814:05
kkeithleyand my control file has Build-Depends: on libntirpc-dev from that ppa.  If the Build-Depends is libntirpc-dev (>= 1.8.1) then it finds it (seen in the build.log) but installs libntirpc-dev_3.0 from the base repos.14:07
kkeithleyAnd if the Build-Depends is libntirpc-dev (= 1.8.1) it someone doesn't see it.14:08
kkeithleyhow can I get it to ignore the newer libntirpc* bits from the base repos and use the one from my ppa?14:09
kkeithleyThis is for groovy mainly and focal too.14:11
cjwatsonkkeithley: It's not about the dependency being newer in the base archive; it's that (= 1.8.1) isn't the correct way to spell that constraint14:12
cjwatsonkkeithley: (= 1.8.1) means that the version has to be *exactly* equal to "1.8.1", and e.g. "1.8.1-1ubuntu1~groovy1" isn't14:12
kkeithleyah, okay. :-/14:13
cjwatsonkkeithley: Perhaps you want something like libntirpc-dev (>= 1.8.1), libntirpc-dev (<< 1.8.2) or similar14:13
kkeithleyI'll give that a try. thanks14:14
cjwatson(Does libntirpc 3.0 not work then?  I've only used nfs-ganesha on bionic really)14:14
kkeithleythere are api/abi changes between 1.8.x and 3.x14:15
cjwatsonBut in fact in https://launchpad.net/~nfs-ganesha-charmers/+archive/ubuntu/backports/+packages we specifically had to backport 3.014:15
cjwatsonWhich is with nfs-ganesha 2.7.4, but that's older than what you're using14:15
cjwatson(I'm a bit busy today, but we should probably talk at some point.  We use nfs-ganesha in the infrastructure for git.launchpad.net.)14:17
kkeithleynot sure I follow.  ganesha 2.7.x should use libntirpc 1.7.x.    ganesha-2.8.x should use libntirpc 1.8.x, and ganesha 3.x should use libntirpc 3.x14:17
kkeithleyhappy to chat when you have time14:17
cjwatsonOh, I know, that PPA is confusing because I had intended to finish the backport of ganesha 3.x but I stopped part-way through for reasons.  Sorry for the red herring there14:18
cjwatsonSo you may actually want more like libntirpc-dev (>= 1.8.1), libntirpc-dev (<< 3.0) or similar, depending on what the true upper bound is14:19
kkeithleyso, even with that change, the build.log says: sbuild-build-depends-nfs-ganesha-dummy : Depends: libntirpc-dev (< 1.8.2) but 3.2-2ubuntu1 is to be installed14:28
kkeithleyE: Unable to correct problems, you have held broken packages.14:28
cjwatsonHmm, this may be an apt limitation14:30
cjwatson(Launchpad only has a limited amount of control here)14:31
cjwatsonIt's possible that the only way around it is to rename the libntirpc-dev and libntirpc1 packages for series that have newer versions in baseline Ubuntu14:32
cjwatsonWhich is a pain, sorry14:33
cjwatson(Well, that isn't entirely true, in theory Launchpad could use pinning to control things more precisely, but that isn't something we do at all at the moment and (a) it's not clear how it would be specified, (b) it wouldn't automatically make things work for users of that PPA who would probably end up with a similar problem)14:34
kkeithleynp. If the base has a newer version then I don't actually know why someone would want to run the older version.  I was building them mainly for foolish consistency.14:34
cjwatsonLooks like focal has 3.0.3, groovy 3.214:36

Generated by irclog2html.py 2.7 by Marius Gedminas - find it at mg.pov.lt!